summaryrefslogtreecommitdiff
path: root/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 07:59:50 +0100
commit2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (patch)
tree69a469da2fa8c3f4920325ac5595300929f5d884 /sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
parent9ed0c42eb618229fa6f45e10155ee535e1f605a2 (diff)
gentoo auto-resync : 20:10:2022 - 07:59:49
Diffstat (limited to 'sys-fs/dislocker/dislocker-0.7.1-r3.ebuild')
-rw-r--r--sys-fs/dislocker/dislocker-0.7.1-r3.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild b/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
deleted file mode 100644
index 90375bf7590b..000000000000
--- a/sys-fs/dislocker/dislocker-0.7.1-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindRuby"
-inherit cmake flag-o-matic
-
-DESCRIPTION="Read BitLocker encrypted partitions"
-HOMEPAGE="https://github.com/Aorimn/dislocker"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~juippis/distfiles/tmp/dislocker-0.7.1-fix-find-ruby.patch"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ruby"
-
-DEPEND="
- sys-fs/fuse:0=
- net-libs/mbedtls:0=
- ruby? ( dev-lang/ruby:* )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- if use ruby && [[ ${PV} == "0.7.1" ]]; then
- PATCHES=( "${DISTDIR}/${P}-fix-find-ruby.patch" )
- fi
- cmake_src_prepare
-
-# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
-# sed 's:Werror:Wno-error:g' -i "src/CMakeLists.txt" || die
- sed 's:-D_FORTIFY_SOURCE=2::g' -i "src/CMakeLists.txt" || die
-
-# sed 's:\.\./man:'../../${P}/man':g' -i "src/CMakeLists.txt" || die
-# Do not process compressed versions of the manuals
- sed -r 's:( create_symlink \$\{BIN_FUSE\}\.1)\.gz (.+\.1)\.gz\\:\1 \2\\:' -i "src/CMakeLists.txt" || die
- sed -r 's:^(.+\.1\.gz):#\1:' -i "src/CMakeLists.txt" || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package ruby Ruby)
- )
- cmake_src_configure
-}
-
-src_install() {
- if ! use ruby; then
- rm "${S}/man/linux/${PN}-find.1" || die
- fi
- find "${S}/man/linux" -name '*.1' -exec doman '{}' + || die
- cmake_src_install
-}