summaryrefslogtreecommitdiff
path: root/sys-fs/dfc/dfc-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /sys-fs/dfc/dfc-3.1.1.ebuild
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'sys-fs/dfc/dfc-3.1.1.ebuild')
-rw-r--r--sys-fs/dfc/dfc-3.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/dfc/dfc-3.1.1.ebuild b/sys-fs/dfc/dfc-3.1.1.ebuild
new file mode 100644
index 000000000000..d13715350a12
--- /dev/null
+++ b/sys-fs/dfc/dfc-3.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="A simple CLI tool that display file system usage, with colors"
+HOMEPAGE="http://projects.gw-computing.net/projects/dfc"
+SRC_URI="http://projects.gw-computing.net/attachments/download/615/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls"
+
+DEPEND="nls? (
+ virtual/libintl
+ sys-devel/gettext
+)"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_configure() {
+ mycmakeargs=(
+ # avoid installing xdg config in /usr
+ -DXDG_CONFIG_DIR="${EPREFIX}"/etc/xdg
+ # use the standard Gentoo doc path
+ -DDFC_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ # disable automagic dependency
+ -DNLS_ENABLED="$(usex nls)"
+ -DLFS_ENABLED=ON
+ -DGRIM=OFF
+ )
+
+ cmake-utils_src_configure
+}