summaryrefslogtreecommitdiff
path: root/sys-fs/dd-rescue/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /sys-fs/dd-rescue/files
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'sys-fs/dd-rescue/files')
-rw-r--r--sys-fs/dd-rescue/files/dd-rescue-1.99.8-xattr.patch300
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch21
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch161
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-musl.patch90
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-test_fix.patch11
5 files changed, 300 insertions, 283 deletions
diff --git a/sys-fs/dd-rescue/files/dd-rescue-1.99.8-xattr.patch b/sys-fs/dd-rescue/files/dd-rescue-1.99.8-xattr.patch
new file mode 100644
index 000000000000..39e719c33861
--- /dev/null
+++ b/sys-fs/dd-rescue/files/dd-rescue-1.99.8-xattr.patch
@@ -0,0 +1,300 @@
+--- dd_rescue-1.99.8/configure.in
++++ dd_rescue-1.99.8/configure.in
+@@ -6,7 +6,7 @@
+ AC_HEADER_STDC
+ #AC_PROG_INSTALL
+ #CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
+-AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h attr/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
++AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h sys/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
+ AC_CHECK_FUNCS([ffs ffsl basename fallocate64 splice getopt_long open64 pread pread64 lseek64 stat64 posix_fadvise posix_fadvise64 __builtin_prefetch htobe64 feof_unlocked getline getentropy getrandom posix_memalign valloc sched_yield fstatvfs __builtin_cpu_supports])
+ AC_CHECK_LIB(dl,dlsym)
+ AC_CHECK_LIB(fallocate,linux_fallocate64)
+--- dd_rescue-1.99.8/dd_rescue.c
++++ dd_rescue-1.99.8/dd_rescue.c
+@@ -161,8 +161,8 @@
+ #endif
+
+ /* xattrs */
+-#ifdef HAVE_ATTR_XATTR_H
+-# include <attr/xattr.h>
++#ifdef HAVE_SYS_XATTR_H
++# include <sys/xattr.h>
+ #else
+ /* TODO: Could provide the prototypes for the syscalls ourselves ... */
+ # warning No support for copying extended attributes / ACLs
+@@ -1276,7 +1276,7 @@
+
+ /** Copy xattrs */
+ int copyxattr(const char* inm, const char* onm)
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ {
+ char *attrs = NULL;
+ ssize_t aln = listxattr(inm, NULL, 0);
+@@ -2486,7 +2486,7 @@
+ #ifdef FITRIM
+ fprintf(stderr, "fitrim ");
+ #endif
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ fprintf(stderr, "xattr ");
+ #endif
+ #if (defined(__x86_64__) || defined(__i386__)) && !defined(NO_RDRND)
+--- dd_rescue-1.99.8/libddr_crypt.c
++++ dd_rescue-1.99.8/libddr_crypt.c
+@@ -47,8 +47,8 @@
+ #include <endian.h>
+ #include <signal.h>
+
+-#ifdef HAVE_ATTR_XATTR_H
+-#include <attr/xattr.h>
++#ifdef HAVE_SYS_XATTR_H
++#include <sys/xattr.h>
+ #endif
+
+ #if __WORDSIZE == 64
+@@ -90,7 +90,7 @@
+ size_t saltlen;
+ loff_t lastpos;
+ loff_t processed;
+-#if 1 //def HAVE_ATTR_XATTR_H
++#if 1 //def HAVE_SYS_XATTR_H
+ char* salt_xattr_name;
+ char sxattr, sxfallback;
+ char* key_xattr_name;
+@@ -113,13 +113,13 @@
+ " Parameters: [alg[o[rithm]]=]ALG:enc[rypt]:dec[rypt]:engine=STR:pad=STR\n"
+ "\t:keyhex=HEX:keyfd=[x]INT[@INT@INT]:keyfile=NAME[@INT@INT]:keygen:keysfile\n"
+ "\t:ivhex=HEX:ivfd=[x]INT[@INT@INT]:ivfile=NAME[@INT@INT]:ivgen:ivsfile\n"
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ "\t:keyxattr[=xattr_name]:kxfallback:ivxattr[=xattr_name]:ixfallback\n"
+ #endif
+ "\t:pass=STR:passfd=[x]INT[@INT@INT]:passfile=NAME[@INT@INT]\n"
+ "\t:salt=STR:salthex=HEX:saltfd=[x]INT[@INT@INT]:saltfile=NAME[@INT@INT]\n"
+ "\t:saltlen=INT:saltgen:saltsfile"
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ ":saltxattr[=xattr_name]:sxfallback"
+ #endif
+ "\n\t:pbkdf2[=INT]:opbkdf[11]:debug:bench[mark]:skiphole:weakrnd:outkeyiv:ctrbug198\n"
+@@ -346,7 +346,7 @@
+ state->saltlen = ATOL(param+8);
+ else if (!strcmp(param, "saltgen"))
+ state->sgen = 1;
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ else if (!strcmp(param, "saltxattr"))
+ err += set_flag(&state->sxattr, "saltxattr");
+ else if (!memcmp(param, "saltxattr=", 10)) {
+@@ -709,7 +709,7 @@
+ return err;
+ }
+
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ int get_xattr(crypt_state *state, const char* atrnm,
+ unsigned char* data, int dlen,
+ char fb, char* fbf, char* flag)
+@@ -883,7 +883,7 @@
+ sprintf(ivsnm, "IVS.%s", state->alg->name);
+ sprintf(keynm, "KEYS.%s", state->alg->name);
+ sprintf(saltnm, "SALT.%s", state->alg->name);
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->sxattr && !state->salt_xattr_name) {
+ state->salt_xattr_name = malloc(32);
+ snprintf(state->salt_xattr_name, 32, "user.salt.%s", state->alg->name);
+@@ -958,7 +958,7 @@
+ }
+
+ /* 5c */
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Try getting salt from xattr */
+ if (!state->sset && state->sxattr && !get_salt_xattr(state) && !state->enc)
+ state->sxattr = 0;
+@@ -999,7 +999,7 @@
+ if (write_file(state->sec->salt, state->sfnm, 8, 0640))
+ return -1;
+ }
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Write salt to xattr */
+ if (state->sxattr && state->enc && set_salt_xattr(state)) {
+ if (!state->sxfallback)
+@@ -1028,7 +1028,7 @@
+ if (!state->keyf && !state->kxattr)
+ FPLOG(WARN, "Generated key not written anywhere?\n", NULL);
+ else {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Write key to xattr, failure is fatal */
+ if (state->kxattr && state->enc && set_key_xattr(state) && !state->kxfallback)
+ return -1;
+@@ -1066,7 +1066,7 @@
+ FPLOG(FATAL, "Key generation with pass+salt failed!\n", NULL);
+ return -1;
+ }
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Write key to xattr, failure is fatal */
+ if (state->kxattr && state->enc && set_key_xattr(state) && !state->kxfallback)
+ return -1;
+@@ -1077,7 +1077,7 @@
+ return -1;
+
+ } else {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->kxattr)
+ get_key_xattr(state);
+ #endif
+@@ -1100,7 +1100,7 @@
+ }
+ }
+ } else {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->kxattr && set_key_xattr(state) && !state->kxfallback) {
+ FPLOG(FATAL, "Can't save key in xattr");
+ return -1;
+@@ -1123,7 +1123,7 @@
+ if (!state->ivf && !state->ixattr)
+ FPLOG(WARN, "Generated IV not saved?\n", NULL);
+ else {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Write IV to xattr, failure w/o fb is fatal */
+ if (state->ixattr && state->enc && set_iv_xattr(state) && !state->ixfallback)
+ return -1;
+@@ -1149,7 +1149,7 @@
+ return -1;
+ }
+ }
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ /* Write IV to xattr, failure w/o fb is fatal */
+ if (state->ixattr && state->enc && set_iv_xattr(state) && !state->ixfallback)
+ return -1;
+@@ -1159,7 +1159,7 @@
+ if (write_keyfile(state, ivsnm, encnm, state->sec->nonce1, BLKSZ, 0640, 1, 0))
+ return -1;
+ } else {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->ixattr)
+ get_iv_xattr(state);
+ #endif
+@@ -1180,7 +1180,7 @@
+ }
+ }
+ } else if (state->alg->stream->needs_iv) {
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->ixattr && set_iv_xattr(state) && !state->ixfallback) {
+ FPLOG(FATAL, "Can't save IV in xattr");
+ return -1;
+@@ -1454,7 +1454,7 @@
+ FPLOG(INFO, "%.2fs CPU time, %.1fMiB/s\n",
+ (double)state->cpu/CLOCKS_PER_SEC,
+ state->processed/1024 / (state->cpu/(CLOCKS_PER_SEC/1024.0)));
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->salt_xattr_name)
+ free(state->salt_xattr_name);
+ if (state->key_xattr_name)
+--- dd_rescue-1.99.8/libddr_hash.c
++++ dd_rescue-1.99.8/libddr_hash.c
+@@ -36,8 +36,8 @@
+ #include <netinet/in.h> /* For ntohl/htonl */
+ #include <endian.h>
+
+-#ifdef HAVE_ATTR_XATTR_H
+-#include <attr/xattr.h>
++#ifdef HAVE_SYS_XATTR_H
++#include <sys/xattr.h>
+ #endif
+ // TODO: pass at runtime rather than compile time
+ #define HASH_DEBUG(x) if (state->debug) x
+@@ -75,7 +75,7 @@
+ #endif
+ int hmacpln;
+ char xfallback;
+-#if 1 //def HAVE_ATTR_XATTR_H
++#if 1 //def HAVE_SYS_XATTR_H
+ char chk_xattr, set_xattr, xnmalloc;
+ char* xattr_name;
+ #endif
+@@ -90,7 +90,7 @@
+ ":multipart=size"
+ #endif
+ "\n"
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ "\t:chk_xattr[=xattr_name]:set_xattr[=xattr_name]:fallb[ack][=FILE]\n"
+ #endif
+ " Use algorithm=help to get a list of supported hash algorithms\n";
+@@ -167,7 +167,7 @@
+ state->append = param+7;
+ else if (!memcmp(param, "prepend=", 8))
+ state->prepend = param+8;
+-#if 1 //def HAVE_ATTR_XATTR_H
++#if 1 //def HAVE_SYS_XATTR_H
+ else if (!memcmp(param, "chk_xattr=", 10)) {
+ state->chk_xattr = 1; state->xattr_name = param+10; }
+ else if (!strcmp(param, "chk_xattr"))
+@@ -258,7 +258,7 @@
+ FPLOG(FATAL, "No hash algorithm specified\n");
+ return --err;
+ }
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if ((state->chk_xattr || state->set_xattr) && !state->xattr_name) {
+ state->xattr_name = (char*)malloc(32);
+ state->xnmalloc = 1;
+@@ -269,7 +269,7 @@
+ }
+ #endif
+ if ((!state->chkfnm || !*state->chkfnm) && (state->chkf || state->outf
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ || state->xfallback
+ #endif
+ )) {
+@@ -301,7 +301,7 @@
+ if (!stat || !(*stat))
+ return -1;
+ hash_state *state = (hash_state*)*stat;
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->xnmalloc)
+ free((void*)state->xattr_name);
+ #endif
+@@ -351,7 +351,7 @@
+ strcat(nnm, "->");
+ strcat(nnm, opt->oname);
+ state->fname = nnm;
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->chk_xattr || state->set_xattr) {
+ --err;
+ FPLOG(WARN, "Can't access xattr in the middle of a plugin chain!");
+@@ -607,7 +607,7 @@
+ return err;
+ }
+
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ int check_xattr(hash_state* state, const char* res)
+ {
+ char xatstr[144];
+@@ -734,7 +734,7 @@
+ err += check_chkf(state, res);
+ if (state->outf)
+ err += write_chkf(state, res);
+-#ifdef HAVE_ATTR_XATTR_H
++#ifdef HAVE_SYS_XATTR_H
+ if (state->chk_xattr)
+ err += check_xattr(state, res);
+ if (state->set_xattr)
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch
deleted file mode 100644
index 244f43121399..000000000000
--- a/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://sourceforge.net/p/ddrescue/tickets/3/
-
---- a/Makefile
-+++ b/Makefile
-@@ -500,11 +500,11 @@ check: $(TARGETS) find_nonzero md5 sha1 sha256 sha512 fmt_no
- # Extra xattrs (should be preserved)
- #make check_xattr_copy
- # Tests with HMAC
-- echo -n "what do ya want for nothing?" > TEST
-- echo "750c783e6ab0b503eaa86e310a5db738 *TEST" > HMACS.md5
-- $(VG) ./dd_rescue -L ./libddr_hash.so=md5:hmacpwd=Jefe:chknm= TEST /dev/null
-- rm -f /tmp/dd_rescue CHECKSUMS.sha512 TEST HMACS.md5
-- if ./calchmac.py sha1 pass dd_rescue; then $(MAKE) check_hmac; else echo "Sorry, no more HMAC test due to missing python-hashlib support"; true; fi
-+ #echo -n "what do ya want for nothing?" > TEST
-+ #echo "750c783e6ab0b503eaa86e310a5db738 *TEST" > HMACS.md5
-+ #$(VG) ./dd_rescue -L ./libddr_hash.so=md5:hmacpwd=Jefe:chknm= TEST /dev/null
-+ #rm -f /tmp/dd_rescue CHECKSUMS.sha512 TEST HMACS.md5
-+ #if ./calchmac.py sha1 pass dd_rescue; then $(MAKE) check_hmac; else echo "Sorry, no more HMAC test due to missing python-hashlib support"; true; fi
- $(MAKE) check_fault
- #$(MAKE) check_aes
- $(MAKE) check_crypt
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch
deleted file mode 100644
index 6751cf009866..000000000000
--- a/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch
+++ /dev/null
@@ -1,161 +0,0 @@
-From 66e7503f24b9693ddb20a0873ae054f799c3660f Mon Sep 17 00:00:00 2001
-From: Thomas Deutschmann <whissi@gentoo.org>
-Date: Mon, 30 Oct 2017 20:12:10 +0100
-Subject: [PATCH 49/49] loff_t and __WORDSIZE includes for MUSL
-
-Rewrite of Justin Keogh's patch [Link 1] to fix build problems
-on ARM.
-
-Link 1: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f5abc0f1b036921d6eb5b0f434c960ed280619f
-Fixes: https://bugs.gentoo.org/616364
----
- configure.in | 2 +-
- ddr_ctrl.h | 3 +++
- ffs.h | 3 +++
- fiemap.h | 4 ++++
- fmt_no.h | 2 ++
- fstrim.h | 3 +++
- libddr_hash.c | 4 ++++
- libddr_lzo.c | 3 +++
- libddr_null.c | 3 +++
- sha512.h | 4 ++++
- 10 files changed, 30 insertions(+), 1 deletion(-)
-
-diff --git a/configure.in b/configure.in
-index f813d4b..c9d28c5 100644
---- a/configure.in
-+++ b/configure.in
-@@ -6,7 +6,7 @@ AC_C_INLINE
- AC_HEADER_STDC
- #AC_PROG_INSTALL
- #CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
--AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h attr/xattr.h sys/acl.h sys/ioctl.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
-+AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h attr/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
- AC_CHECK_FUNCS([ffs ffsl basename fallocate64 splice getopt_long open64 pread pread64 lseek64 stat64 posix_fadvise posix_fadvise64 __builtin_prefetch htobe64 feof_unlocked getline getentropy getrandom posix_memalign valloc sched_yield fstatvfs])
- AC_CHECK_LIB(dl,dlsym)
- AC_CHECK_LIB(fallocate,linux_fallocate64)
-diff --git a/ddr_ctrl.h b/ddr_ctrl.h
-index ac71e4f..58cffd5 100644
---- a/ddr_ctrl.h
-+++ b/ddr_ctrl.h
-@@ -7,6 +7,9 @@
- * License: GNU GPLv2 or v3
- */
-
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-+
- #ifndef _DDR_CTRL_H
- #define _DDR_CTRL_H
-
-diff --git a/ffs.h b/ffs.h
-index 2215080..c1f3444 100644
---- a/ffs.h
-+++ b/ffs.h
-@@ -28,6 +28,9 @@
- #include <endian.h>
- #endif
-
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
-
- #ifdef HAVE_FFS
- # define myffs(x) ffs(x)
-diff --git a/fiemap.h b/fiemap.h
-index df1ba95..31cde3b 100644
---- a/fiemap.h
-+++ b/fiemap.h
-@@ -29,5 +29,9 @@
-
- #endif /* HAVE_LINUX_FS_H */
-
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
-+
- #endif /* _FIEMAPH */
-
-diff --git a/fmt_no.h b/fmt_no.h
-index 329f997..16eda5c 100644
---- a/fmt_no.h
-+++ b/fmt_no.h
-@@ -1,4 +1,6 @@
- /** Decl for int to str conversion with highlighting */
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-
- #ifndef _FMT_NO_H
- #define _FMT_NO_H
-diff --git a/fstrim.h b/fstrim.h
-index 7447061..b9cdcbb 100644
---- a/fstrim.h
-+++ b/fstrim.h
-@@ -1,3 +1,6 @@
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-+
- #ifndef _FSTRIM_H
- #define _FSTRIM_H
-
-diff --git a/libddr_hash.c b/libddr_hash.c
-index daa806e..264dba1 100644
---- a/libddr_hash.c
-+++ b/libddr_hash.c
-@@ -33,6 +33,10 @@
- #include <unistd.h>
- #include <fcntl.h>
-
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
-+
- #include <netinet/in.h> /* For ntohl/htonl */
- #include <endian.h>
-
-diff --git a/libddr_lzo.c b/libddr_lzo.c
-index 531df11..3220e2a 100644
---- a/libddr_lzo.c
-+++ b/libddr_lzo.c
-@@ -26,6 +26,9 @@
- #include <errno.h>
- #include <netinet/in.h>
- #include <sys/stat.h>
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
- #include <signal.h>
- #include <lzo/lzo1x.h>
- #include <lzo/lzo1y.h>
-diff --git a/libddr_null.c b/libddr_null.c
-index 3f0f194..c379961 100644
---- a/libddr_null.c
-+++ b/libddr_null.c
-@@ -10,6 +10,9 @@
- #include "ddr_ctrl.h"
- #include <string.h>
- #include <stdlib.h>
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
-
- /* fwd decl */
- extern ddr_plugin_t ddr_plug;
-diff --git a/sha512.h b/sha512.h
-index 4d08043..f54d371 100644
---- a/sha512.h
-+++ b/sha512.h
-@@ -3,6 +3,10 @@
-
- #include "hash.h"
-
-+#ifdef HAVE_SYS_REG_H
-+#include <sys/reg.h>
-+#endif
-+
- void sha512_init(hash_t *ctx);
- void sha384_init(hash_t *ctx);
- void sha512_128(const uint8_t* msg, hash_t* ctx);
---
-2.14.3
-
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-musl.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-musl.patch
deleted file mode 100644
index 6647e5f687c6..000000000000
--- a/sys-fs/dd-rescue/files/dd_rescue-1.99-musl.patch
+++ /dev/null
@@ -1,90 +0,0 @@
---- a/ffs.h 2016-02-09 03:37:14.422639513 +0000
-+++ b/ffs.h 2016-02-09 03:38:59.843641094 +0000
-@@ -27,7 +27,8 @@
- #ifdef HAVE_ENDIAN_H
- #include <endian.h>
- #endif
--
-+/* __WORDSIZE */
-+#include <sys/reg.h>
-
- #ifdef HAVE_FFS
- # define myffs(x) ffs(x)
---- a/fiemap.h 2016-02-09 03:45:05.550646582 +0000
-+++ b/fiemap.h 2016-02-09 03:45:56.683647349 +0000
-@@ -31,3 +31,4 @@
-
- #endif /* _FIEMAPH */
-
-+#include <sys/reg.h>
---- a/libddr_hash.c 2016-02-09 03:49:16.334650345 +0000
-+++ b/libddr_hash.c 2016-02-09 03:50:01.309651020 +0000
-@@ -32,6 +32,7 @@
- #include <errno.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <sys/reg.h>
-
- #include <netinet/in.h> /* For ntohl/htonl */
- #include <endian.h>
---- a/libddr_lzo.c 2016-02-09 03:52:31.775653278 +0000
-+++ b/libddr_lzo.c 2016-02-09 03:52:53.537653604 +0000
-@@ -26,6 +26,7 @@
- #include <errno.h>
- #include <netinet/in.h>
- #include <sys/stat.h>
-+#include <sys/reg.h>
- #include <signal.h>
- #include <lzo/lzo1x.h>
- #include <lzo/lzo1y.h>
---- a/libddr_null.c 2016-02-09 03:54:04.110654663 +0000
-+++ b/libddr_null.c 2016-02-09 03:54:18.018654872 +0000
-@@ -10,6 +10,7 @@
- #include "ddr_ctrl.h"
- #include <string.h>
- #include <stdlib.h>
-+#include <sys/reg.h>
-
- /* fwd decl */
- extern ddr_plugin_t ddr_plug;
---- a/sha512.h 2016-02-09 03:55:33.209656000 +0000
-+++ b/sha512.h 2016-02-09 03:56:39.923657001 +0000
-@@ -2,6 +2,8 @@
- #define _SHA512_H
-
- #include "hash.h"
-+/* __WORDSIZE */
-+#include <sys/reg.h>
-
- void sha512_init(hash_t *ctx);
- void sha384_init(hash_t *ctx);
---- a/fmt_no.h 2016-02-09 04:52:13.760707026 +0000
-+++ b/fmt_no.h 2016-02-09 04:52:50.874707583 +0000
-@@ -1,4 +1,6 @@
- /** Decl for int to str conversion with highlighting */
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-
- #ifndef _FMT_NO_H
- #define _FMT_NO_H
---- a/fstrim.h 2016-02-09 04:55:43.871710178 +0000
-+++ b/fstrim.h 2016-02-09 04:56:11.270710590 +0000
-@@ -1,3 +1,6 @@
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-+
- #ifndef _FSTRIM_H
- #define _FSTRIM_H
-
---- a/ddr_ctrl.h 2016-02-09 04:58:08.442712348 +0000
-+++ b/ddr_ctrl.h 2016-02-09 04:58:50.842712984 +0000
-@@ -7,6 +7,9 @@
- * License: GNU GPLv2 or v3
- */
-
-+#define _GNU_SOURCE
-+#include <fcntl.h>
-+
- #ifndef _DDR_CTRL_H
- #define _DDR_CTRL_H
-
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-test_fix.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-test_fix.patch
deleted file mode 100644
index 6ddf7116f9fb..000000000000
--- a/sys-fs/dd-rescue/files/dd_rescue-1.99-test_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dd_rescue-1.99/test_crypt.sh
-+++ dd_rescue-1.99/test_crypt.sh
-@@ -97,7 +97,7 @@
- $VG ./dd_rescue -t -m 4096 urandom urandom.new || exit 1
- # Ensure that we don't have 01 or 02 02 or ... at the end,
- # which would trip pad=asneeded
--echo -n "a" | dd_rescue -S 4095 -m 1 - urandom.new
-+echo -n "a" | ./dd_rescue -S 4095 -m 1 - urandom.new
- mv urandom.new urandom
- enc_dec_compare_keys urandom AES192-CBC "" pad=always "" "-qpt"
- enc_dec_compare_keys urandom AES192-CBC "" pad=asneeded "" "-qpt"