summaryrefslogtreecommitdiff
path: root/sys-fs/davl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/davl/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/davl/files')
-rw-r--r--sys-fs/davl/files/davl-1.2.1-asneeded.patch41
-rw-r--r--sys-fs/davl/files/davl-1.2.4-fragment.patch20
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/davl/files/davl-1.2.1-asneeded.patch b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
new file mode 100644
index 000000000000..819d16d09e75
--- /dev/null
+++ b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
@@ -0,0 +1,41 @@
+--- a/src/cdavl/Makefile
++++ b/src/cdavl/Makefile
+@@ -4,10 +4,6 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-DEBUG =
+-#DEBUG = -DDEBUG
+-CFLAGS = -Wall -g -O -D_FILE_OFFSET_BITS=64 $(DEBUG)
+ HEADERS = cdavl.h ../common/util.h ../drv/liveinfo_app.h
+ OBJS = ../common/util.o
+ CDAVL = cdavl
+--- a/src/gdavl/Makefile
++++ b/src/gdavl/Makefile
+@@ -4,22 +4,14 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-CFLAGS1 = -Wall -g -O `gtk-config --cflags --libs`
+-CFLAGS2 = -Wall -g -O `pkg-config --cflags --libs gtk+-2.0`
+-CFLAGS = -D$(GTK_VER)
+-ifeq ($(GTK_VER), GTK2)
+- CFLAGS += $(CFLAGS2)
+-else
+- CFLAGS += $(CFLAGS1)
+-endif
++CFLAGS += -D$(GTK_VER) `pkg-config --cflags gtk+-2.0`
++LDLIBS = `pkg-config --libs gtk+-2.0`
+ DEBUG =
+ #DEBUG = -D DEBUG
+ GDAVL = gdavl
+
+
+-$(GDAVL): gdavl.c if.c gdavl.h
+- $(CC) $(CFLAGS) $(DEBUG) -o $(GDAVL) gdavl.c if.c
++$(GDAVL): gdavl.o if.o
+
+ clean:
+ rm -rf $(GDAVL) *.o test/*.png test/log test/test.log
diff --git a/sys-fs/davl/files/davl-1.2.4-fragment.patch b/sys-fs/davl/files/davl-1.2.4-fragment.patch
new file mode 100644
index 000000000000..a6b2e40b240a
--- /dev/null
+++ b/sys-fs/davl/files/davl-1.2.4-fragment.patch
@@ -0,0 +1,20 @@
+cdavl.c:101:53: error: ‘struct ext2_super_block’ has no member named ‘s_log_frag_size’
+cdavl.c:105:53: error: ‘struct ext2_super_block’ has no member named ‘s_frags_per_group’
+
+http://bugs.gentoo.org/425820
+
+--- a/src/cdavl/cdavl.c
++++ b/src/cdavl/cdavl.c
+@@ -98,9 +98,11 @@
+ PRINT4("s_free_inodes_count: ", le32_to_cpu(sb->s_free_inodes_count));
+ PRINT4("s_first_data_block: ", le32_to_cpu(sb->s_first_data_block));
+ PRINT4("s_log_block_size: ", le32_to_cpu(sb->s_log_block_size));
++ #if 0
+ PRINT4("s_log_frag_size: ", le32_to_cpu(sb->s_log_frag_size));
+- PRINT4("s_blocks_per_group: ", le32_to_cpu(sb->s_blocks_per_group));
+ PRINT4("s_frags_per_group: ", le32_to_cpu(sb->s_frags_per_group));
++ #endif
++ PRINT4("s_blocks_per_group: ", le32_to_cpu(sb->s_blocks_per_group));
+ PRINT4("s_inodes_per_group: ", le32_to_cpu(sb->s_inodes_per_group));
+ PRINT4("s_mtime: ", le32_to_cpu(sb->s_mtime));
+ PRINT4("s_wtime: ", le32_to_cpu(sb->s_wtime));