summaryrefslogtreecommitdiff
path: root/sys-fs/compsize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-fs/compsize
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-fs/compsize')
-rw-r--r--sys-fs/compsize/Manifest6
-rw-r--r--sys-fs/compsize/compsize-1.3.ebuild41
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild30
-rw-r--r--sys-fs/compsize/metadata.xml12
4 files changed, 72 insertions, 17 deletions
diff --git a/sys-fs/compsize/Manifest b/sys-fs/compsize/Manifest
index d0f884598977..fcaea01166da 100644
--- a/sys-fs/compsize/Manifest
+++ b/sys-fs/compsize/Manifest
@@ -1,4 +1,6 @@
DIST compsize-1.1.tar.gz 14345 BLAKE2B 8b35e6f3526b8b2395972ea1a595011b867fbc076d79c90c66a19853f1b101dbe3decedab8244d893b20d6cc9ff3ecfa2b3320fc12c583415b2d446a9298fcb1 SHA512 1c7de5156b695ffa4be9b634fd6224214d3de1653eb23e5d85b250e27146fe655883bed17ed458bae1b448ed9ae8a254d2a673fdb3860e69c99f8676daea0d8b
+DIST compsize-1.3.tar.gz 14782 BLAKE2B 738ff0e2b936f5974064759914284e495c895d22d95b705e1b8fac4b3189891771b0e5be7e0eeac0883dd92f9cef276400bb7ee79840fd7db14a5269e7f78f11 SHA512 411b92651fdc3d03deccbf38f72936fee95cf80c67d6368efbc0dafacfe9793815a23ef0d02f7feadf31391e415df3d90cd19fb3acc8cce94f37cb3e4eed623d
EBUILD compsize-1.1.ebuild 940 BLAKE2B aae5bb225b287ece48d4bffc921d95837bcc5c48affc88ccf55eb6565943994bfa08eaf8be6cfeaf4c86cde3aca37946d6cc50ea10fa679d10e557c2b207090f SHA512 b97df62447581e46b6b7276044861ab1900b77055e0a8f0989fa46dce204bd52ad000d66a1662133fe581d8aa354b4c1214596c83547267997628f54c2172c5e
-EBUILD compsize-9999.ebuild 940 BLAKE2B aae5bb225b287ece48d4bffc921d95837bcc5c48affc88ccf55eb6565943994bfa08eaf8be6cfeaf4c86cde3aca37946d6cc50ea10fa679d10e557c2b207090f SHA512 b97df62447581e46b6b7276044861ab1900b77055e0a8f0989fa46dce204bd52ad000d66a1662133fe581d8aa354b4c1214596c83547267997628f54c2172c5e
-MISC metadata.xml 166 BLAKE2B df899de61ee57cf9c2d5822a8ca4cb62c697c6da7142003688afbdd1261a8623d48058189ebe005c053ffddcb9f7275f19a0e48fc47ce1890341e276400f1d8f SHA512 12bfcd38af9dc9fe67b866a4ae090e26873d363409efc5949cca4b4a59ba0d770b09ebec8a108482b29b94c922bcdb8ce3f5ccbb578137b44e35bd783b4c9472
+EBUILD compsize-1.3.ebuild 962 BLAKE2B 6a1acd0d8c62796e6c0159f453bac412f57ae4afdc9c20f8794518f9a12f25961f55ffc493916496455b7f9d5e253de9c02379e28b73f17fd2cf50c4c250aacd SHA512 d1a5530f238ff30fd311d38a47e30ba9e0db668b426c789de6dd0c2654f94d910cbae423e49042fec940daf8e557d2872f6c7514b15fdbb37e5cc23ef3672ae5
+EBUILD compsize-9999.ebuild 1086 BLAKE2B 99aa3fe99ee99f19ee8beb7328dc9bb1af8288111a6b8e52b0551ecc1cf818f9d2ff7e939ed88a40493e421e1afe2c56cd69a64e92bd5d788517d0ea997c31ba SHA512 4e54a226690115710a9ea85d05a77448b593e5657a9392f52570ef1f4d70770d8b7bfa5a666c6fda50270fafaba9f7009059fb8e4a30230e7e4c5c7d5d2c0259
+MISC metadata.xml 444 BLAKE2B 0eacf312059aaec47fa5f5036bc09afccf3275819b8e2890a02130d9e142020945f68d3e155cee27e18d6c061ddbbd6de71231beeab8a4b29e5535ad84db308c SHA512 1c03b76ef3eae52b3212d7f1a8b2e822ac24dcad2a95ed078d4819a7084e6e701f76ce3c17e38efaaeaede24357126cbf54e311c6b2a5c26e75299971ac7649e
diff --git a/sys-fs/compsize/compsize-1.3.ebuild b/sys-fs/compsize/compsize-1.3.ebuild
new file mode 100644
index 000000000000..df2657574f74
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ use debug && append-cflags -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}" install
+ dodoc "README.md"
+}
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
index ad73046823bd..3144e142c1e2 100644
--- a/sys-fs/compsize/compsize-9999.ebuild
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic
-DESCRIPTION="Utility to find btrfs compression ratio"
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
HOMEPAGE="https://github.com/kilobyte/compsize"
if [[ ${PV} = 9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
else
- KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2+"
-SLOT=0
+IUSE="debug"
+SLOT="0"
-RDEPEND=""
DEPEND="sys-fs/btrfs-progs"
src_prepare() {
- eapply_user
- # Don't try to install a gzipped manfile during make install, instead
- # use doman in src_install to ensure that PORTAGE_COMPRESS is used
- sed -i $'/^\tgzip /d' Makefile || die
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+ # sys-fs/compsize > 1.3 removes '/usr' from install paths in Makefile
+ sed -i $'s/(PREFIX)/(PREFIX)\/usr/' Makefile || die
}
src_configure() {
# Used in upstream Makefile, but clobbered by portage's CFLAGS
append-cflags -Wall -std=gnu90
+ use debug && append-cflags -DDEBUG -g
default
}
src_install() {
- emake PREFIX="${ED%/}" install
- doman compsize.8
- einstalldocs
+ emake PREFIX="${D}" install
+ dodoc "README.md"
}
diff --git a/sys-fs/compsize/metadata.xml b/sys-fs/compsize/metadata.xml
index c1744fe7fc5b..289d3a1d5b6a 100644
--- a/sys-fs/compsize/metadata.xml
+++ b/sys-fs/compsize/metadata.xml
@@ -1,5 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--maintainer-needed-->
+ <maintainer type="person">
+ <email>telans@posteo.de</email>
+ <name>Theo Anderson</name>
+ </maintainer>
+ <maintainer type="project">
+ <name>Proxy Maintainers</name>
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kilobyte/compsize</remote-id>
+ </upstream>
</pkgmetadata>