summaryrefslogtreecommitdiff
path: root/sys-fs/compsize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-31 10:55:17 +0100
commit75fc75ae1f0481ffdb78450e801a9b443ba641bd (patch)
treecef96ea0860ae39a202bbf1e226100335209627d /sys-fs/compsize
parent1173ad5704ce725916e0c332416aff326d850d06 (diff)
gentoo resync : 31.03.2018
Diffstat (limited to 'sys-fs/compsize')
-rw-r--r--sys-fs/compsize/Manifest4
-rw-r--r--sys-fs/compsize/compsize-1.1.ebuild41
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild41
-rw-r--r--sys-fs/compsize/metadata.xml11
4 files changed, 97 insertions, 0 deletions
diff --git a/sys-fs/compsize/Manifest b/sys-fs/compsize/Manifest
new file mode 100644
index 000000000000..280c857b8f28
--- /dev/null
+++ b/sys-fs/compsize/Manifest
@@ -0,0 +1,4 @@
+DIST compsize-1.1.tar.gz 14345 BLAKE2B 8b35e6f3526b8b2395972ea1a595011b867fbc076d79c90c66a19853f1b101dbe3decedab8244d893b20d6cc9ff3ecfa2b3320fc12c583415b2d446a9298fcb1 SHA512 1c7de5156b695ffa4be9b634fd6224214d3de1653eb23e5d85b250e27146fe655883bed17ed458bae1b448ed9ae8a254d2a673fdb3860e69c99f8676daea0d8b
+EBUILD compsize-1.1.ebuild 940 BLAKE2B aae5bb225b287ece48d4bffc921d95837bcc5c48affc88ccf55eb6565943994bfa08eaf8be6cfeaf4c86cde3aca37946d6cc50ea10fa679d10e557c2b207090f SHA512 b97df62447581e46b6b7276044861ab1900b77055e0a8f0989fa46dce204bd52ad000d66a1662133fe581d8aa354b4c1214596c83547267997628f54c2172c5e
+EBUILD compsize-9999.ebuild 940 BLAKE2B aae5bb225b287ece48d4bffc921d95837bcc5c48affc88ccf55eb6565943994bfa08eaf8be6cfeaf4c86cde3aca37946d6cc50ea10fa679d10e557c2b207090f SHA512 b97df62447581e46b6b7276044861ab1900b77055e0a8f0989fa46dce204bd52ad000d66a1662133fe581d8aa354b4c1214596c83547267997628f54c2172c5e
+MISC metadata.xml 344 BLAKE2B fdc606b6541dd72532969c177a7d8b6f5e80f27643df091b43fc497a803636152648d8baab08097cffa0ae04e5b840815f204ab5afe51194f09d2fe87c7db09e SHA512 6073215942dbca66eebe8b22151ac1e166ab4d06a1f230519db75cc783e8b307387f0160cb172f4e38860944052b7e20d17f0384142328f979acbc979c2d5b41
diff --git a/sys-fs/compsize/compsize-1.1.ebuild b/sys-fs/compsize/compsize-1.1.ebuild
new file mode 100644
index 000000000000..ad73046823bd
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression ratio"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2+"
+SLOT=0
+
+RDEPEND=""
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ eapply_user
+ # Don't try to install a gzipped manfile during make install, instead
+ # use doman in src_install to ensure that PORTAGE_COMPRESS is used
+ sed -i $'/^\tgzip /d' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED%/}" install
+ doman compsize.8
+ einstalldocs
+}
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
new file mode 100644
index 000000000000..ad73046823bd
--- /dev/null
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression ratio"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2+"
+SLOT=0
+
+RDEPEND=""
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ eapply_user
+ # Don't try to install a gzipped manfile during make install, instead
+ # use doman in src_install to ensure that PORTAGE_COMPRESS is used
+ sed -i $'/^\tgzip /d' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED%/}" install
+ doman compsize.8
+ einstalldocs
+}
diff --git a/sys-fs/compsize/metadata.xml b/sys-fs/compsize/metadata.xml
new file mode 100644
index 000000000000..7f4384fb84c6
--- /dev/null
+++ b/sys-fs/compsize/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>adebeus@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>