summaryrefslogtreecommitdiff
path: root/sys-fs/compsize/compsize-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-fs/compsize/compsize-1.3.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-fs/compsize/compsize-1.3.ebuild')
-rw-r--r--sys-fs/compsize/compsize-1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/compsize/compsize-1.3.ebuild b/sys-fs/compsize/compsize-1.3.ebuild
new file mode 100644
index 000000000000..df2657574f74
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ use debug && append-cflags -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}" install
+ dodoc "README.md"
+}