summaryrefslogtreecommitdiff
path: root/sys-fs/btrfs-progs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/btrfs-progs/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/btrfs-progs/files')
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-3.14.2-install-man.patch13
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-4.8.1-fix-ioctl.h36
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-4.8.3-fix-ioctl-again.patch9
3 files changed, 58 insertions, 0 deletions
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-3.14.2-install-man.patch b/sys-fs/btrfs-progs/files/btrfs-progs-3.14.2-install-man.patch
new file mode 100644
index 000000000000..69e36aaadeba
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-3.14.2-install-man.patch
@@ -0,0 +1,13 @@
+diff --git a/Documentation/Makefile b/Documentation/Makefile
+index 034559e..f461bf2 100644
+--- a/Documentation/Makefile
++++ b/Documentation/Makefile
+@@ -75,7 +75,7 @@ install: install-man
+ install-man: man
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
+ $(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
+- $(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)
++ $(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
+
+ clean:
+ $(RM) *.xml *.xml+ *.8 *.8.gz
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-4.8.1-fix-ioctl.h b/sys-fs/btrfs-progs/files/btrfs-progs-4.8.1-fix-ioctl.h
new file mode 100644
index 000000000000..61b60c78faae
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-4.8.1-fix-ioctl.h
@@ -0,0 +1,36 @@
+commit 3ddbf895db678fb40f7513bac9dbc36fd4095693
+Author: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Mon Oct 24 09:08:53 2016 +0100
+
+ ioctl.h: add missing kernel compatibility header for BUILD_ASSERT
+
+ Header breakage noticed by cynede. Reproducible as:
+
+ $ gcc -c /usr/include/btrfs/ioctl.h -o /tmp/a.o
+ /usr/include/btrfs/ioctl.h:42:14: error: expected declaration specifiers or '...' before 'sizeof'
+ BUILD_ASSERT(sizeof(struct btrfs_ioctl_vol_args) == 4096);
+ ^~~~~~
+
+ Basically gcc tries to say us BUILD_ASSERT is not visible.
+
+ BUILD_ASSERT lives in kerncompat.h which this change adds.
+
+ Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+diff --git a/ioctl.h b/ioctl.h
+index a7235c0..abea7ed 100644
+--- a/ioctl.h
++++ b/ioctl.h
+@@ -26,6 +26,12 @@ extern "C" {
+ #include <asm/types.h>
+ #include <linux/ioctl.h>
+
++#if BTRFS_FLAT_INCLUDES
++#include "kerncompat.h"
++#else
++#include <btrfs/kerncompat.h>
++#endif /* BTRFS_FLAT_INCLUDES */
++
+ #ifndef __user
+ #define __user
+ #endif
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-4.8.3-fix-ioctl-again.patch b/sys-fs/btrfs-progs/files/btrfs-progs-4.8.3-fix-ioctl-again.patch
new file mode 100644
index 000000000000..9c894900e4ab
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-4.8.3-fix-ioctl-again.patch
@@ -0,0 +1,9 @@
+diff --git a/ioctl.h b/ioctl.h
+index cdfb888..ad4372c 100644
+--- a/ioctl.h
++++ b/ioctl.h
+@@ -710,3 +710,3 @@ static inline char *btrfs_err_str(enum btrfs_err_code err_code)
+ default:
+- return NULL;
++ return 0;
+ }