summaryrefslogtreecommitdiff
path: root/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-10 17:08:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-10 17:08:48 +0100
commit5b5704b62a0f04d93fd58986b426a31352fe2fd5 (patch)
tree0034259fd845f22388e30e34a06f2fe12537cd30 /sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
parent77ffa9fa127c2f664cbb6aba05848662a904f2ff (diff)
gentoo resync : 10.10.2017
Diffstat (limited to 'sys-fs/btrfs-progs/btrfs-progs-9999.ebuild')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
index fa7bc3eb6b36..0dc40a977f4a 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,7 +24,7 @@ HOMEPAGE="https://btrfs.wiki.kernel.org"
LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
-IUSE="+convert static static-libs"
+IUSE="+convert reiserfs static static-libs"
RESTRICT=test # tries to mount repared filesystems
@@ -35,6 +35,9 @@ RDEPEND="
convert? (
sys-fs/e2fsprogs:0=
sys-libs/e2fsprogs-libs:0=
+ reiserfs? (
+ sys-fs/reiserfsprogs
+ )
)
"
DEPEND="${RDEPEND}
@@ -49,6 +52,9 @@ DEPEND="${RDEPEND}
convert? (
sys-fs/e2fsprogs:0[static-libs(+)]
sys-libs/e2fsprogs-libs:0[static-libs(+)]
+ reiserfs? (
+ sys-fs/reiserfsprogs[static-libs(+)]
+ )
)
)
"
@@ -60,7 +66,7 @@ fi
src_prepare() {
default
if [[ ${PV} == 9999 ]]; then
- eautoreconf
+ AT_M4DIR=m4 eautoreconf
mkdir config || die
local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
[[ -e ${automakedir} ]] || die "Could not locate automake directory"
@@ -75,6 +81,9 @@ src_configure() {
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
$(use_enable elibc_glibc backtrace)
+ # No whitespace due to 'ext2,reiserfs' being invalid
+ # for configure. TODO: Why it's not valid?
+ --with-convert=ext2$(usex reiserfs 'reiserfs' '')
)
econf "${myeconfargs[@]}"
}