summaryrefslogtreecommitdiff
path: root/sys-fs/bindfs/bindfs-1.17.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
commit4d190a87291ace8503ad92c6b049d14660a14c72 (patch)
tree3c46c3d158d4e77a4c12d283a17bade041a9859f /sys-fs/bindfs/bindfs-1.17.7.ebuild
parent3c7931f8c6c90aa813912d87c684d742e0c29a05 (diff)
gentoo auto-resync : 07:04:2024 - 18:30:54
Diffstat (limited to 'sys-fs/bindfs/bindfs-1.17.7.ebuild')
-rw-r--r--sys-fs/bindfs/bindfs-1.17.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/bindfs/bindfs-1.17.7.ebuild b/sys-fs/bindfs/bindfs-1.17.7.ebuild
new file mode 100644
index 000000000000..e72e4409e14b
--- /dev/null
+++ b/sys-fs/bindfs/bindfs-1.17.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="FUSE filesystem for bind mounting with altered permissions"
+HOMEPAGE="https://bindfs.org/"
+SRC_URI="https://bindfs.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=sys-fs/fuse-3.10.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug debug-output) --with-fuse3
+}