summaryrefslogtreecommitdiff
path: root/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-03 10:18:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-03 10:18:28 +0100
commit015fdd57022ab7a54e47dafe3e81ffc76e502a90 (patch)
tree56dd77e496e4038b74a5c7547be2a320a43ca186 /sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
parent778487365a91290a8fd0376883de1a4e874fe27b (diff)
gentoo auto-resync : 03:09:2023 - 10:18:27
Diffstat (limited to 'sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
index e0dd0d66a627..b30dc1f3b7ae 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
@@ -11,9 +11,10 @@ EAPI=8
# [bindgen]="https://gitlab.com/Matt.Jolly/rust-bindgen-bcachefs;f773267b090bf16b9e8375fcbdcd8ba5e88806a8;rust-bindgen-bcachefs-%commit%/bindgen"
# )
+LLVM_MAX_SLOT=17
PYTHON_COMPAT=( python3_{10..12} )
-inherit cargo flag-o-matic multiprocessing python-any-r1 toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm multiprocessing python-any-r1 toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
@@ -34,6 +35,7 @@ IUSE="fuse test"
RESTRICT="!test? ( test )"
DEPEND="
+ fuse? ( >=sys-fs/fuse-3.7.0 )
app-arch/lz4
dev-libs/libaio
dev-libs/libsodium
@@ -42,11 +44,11 @@ DEPEND="
sys-apps/util-linux
sys-libs/zlib
virtual/udev
- fuse? ( >=sys-fs/fuse-3.7.0 )
"
RDEPEND="${DEPEND}"
+# Clang is required for bindgen
BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
@@ -57,10 +59,15 @@ BDEPEND="
)
')
$(unpacker_src_uri_depends)
- sys-devel/clang
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1))
+ virtual/pkgconfig
virtual/rust
"
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}"
+}
+
python_check_deps() {
if use test; then
python_has_version \
@@ -68,7 +75,11 @@ python_check_deps() {
"dev-python/pytest-xdist[${PYTHON_USEDEP}]"
fi
python_has_version "dev-python/docutils[${PYTHON_USEDEP}]"
+}
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
}
src_unpack() {
@@ -76,7 +87,7 @@ src_unpack() {
git-r3_src_unpack
S="${S}/rust-src" cargo_live_src_unpack
else
- default
+ unpack ${P}.tar.gz
cargo_src_unpack
fi
}