summaryrefslogtreecommitdiff
path: root/sys-fs/bashmount/bashmount-4.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-fs/bashmount/bashmount-4.3.2-r1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-fs/bashmount/bashmount-4.3.2-r1.ebuild')
-rw-r--r--sys-fs/bashmount/bashmount-4.3.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/bashmount/bashmount-4.3.2-r1.ebuild b/sys-fs/bashmount/bashmount-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..3c4c85c7c4ed
--- /dev/null
+++ b/sys-fs/bashmount/bashmount-4.3.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bash script that uses udisks to mount removable devices without GUI"
+HOMEPAGE="https://github.com/jamielinux/bashmount"
+SRC_URI="https://github.com/jamielinux/bashmount/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# sys-apps/util-linux -> lsblk
+RDEPEND="
+ app-shells/bash:*
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-fs/udisks:2"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ doman ${PN}.1
+ dodoc NEWS
+}