summaryrefslogtreecommitdiff
path: root/sys-freebsd/freebsd-libexec/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-freebsd/freebsd-libexec/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-freebsd/freebsd-libexec/files')
-rw-r--r--sys-freebsd/freebsd-libexec/files/bootpd.confd7
-rw-r--r--sys-freebsd/freebsd-libexec/files/bootpd.initd27
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-10.2-atf-check.patch28
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-pic.patch13
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-8.2-rtld.patch40
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch15
-rw-r--r--sys-freebsd/freebsd-libexec/files/ftpd.pamd8
-rw-r--r--sys-freebsd/freebsd-libexec/files/rquotad.xinetd11
-rw-r--r--sys-freebsd/freebsd-libexec/files/rstatd.xinetd11
-rw-r--r--sys-freebsd/freebsd-libexec/files/rusersd.xinetd11
-rw-r--r--sys-freebsd/freebsd-libexec/files/sprayd.xinetd11
-rw-r--r--sys-freebsd/freebsd-libexec/files/walld.xinetd11
12 files changed, 193 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-libexec/files/bootpd.confd b/sys-freebsd/freebsd-libexec/files/bootpd.confd
new file mode 100644
index 000000000000..6d238e4d4853
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/bootpd.confd
@@ -0,0 +1,7 @@
+# Configuration file for /etc/init.d/bootpd
+
+# Name of the configuration file for bootpd
+# bootptab_file="/etc/bootptab"
+
+# Options to pass to bootpd. See bootpd(8).
+# bootpd_opts=""
diff --git a/sys-freebsd/freebsd-libexec/files/bootpd.initd b/sys-freebsd/freebsd-libexec/files/bootpd.initd
new file mode 100644
index 000000000000..82288ebf19c3
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/bootpd.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ local bootptab=${bootptab_file:-/etc/bootptab}
+
+ if ! [ -f "${bootptab}" ]; then
+ eerror "Unable to find the bootptab file: ${bootptab}"
+ eend 1
+ return 1
+ fi
+
+ ebegin "Starting BOOTP server"
+ start-stop-daemon --start --exec /usr/libexec/bootpd -- ${bootpd_opts} ${bootptab}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping BOOTP server"
+ start-stop-daemon --stop --exec /usr/libexec/bootpd
+ eend $?
+}
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-10.2-atf-check.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-10.2-atf-check.patch
new file mode 100644
index 000000000000..e9c092566303
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-10.2-atf-check.patch
@@ -0,0 +1,28 @@
+diff --git a/libexec/atf/Makefile.inc b/libexec/atf/Makefile.inc
+index b50e14e..e59a413 100644
+--- a/libexec/atf/Makefile.inc
++++ b/libexec/atf/Makefile.inc
+@@ -25,7 +25,7 @@
+ #
+ # $FreeBSD: stable/10/libexec/atf/Makefile.inc 271298 2014-09-09 04:00:30Z ngie $
+
+-CFLAGS+= -DHAVE_CONFIG_H
++CXXFLAGS+= -DHAVE_CONFIG_H
+
+ WARNS?= 3
+
+diff --git a/libexec/atf/atf-check/Makefile b/libexec/atf/atf-check/Makefile
+index 77c11db..7449ddb 100644
+--- a/libexec/atf/atf-check/Makefile
++++ b/libexec/atf/atf-check/Makefile
+@@ -34,8 +34,8 @@ PROG_CXX= atf-check
+ SRCS= atf-check.cpp
+ MAN= atf-check.1
+
+-CFLAGS+= -I${ATF}
+-CFLAGS+= -DATF_SHELL='"/bin/sh"'
++CXXFLAGS+= -I${ATF}
++CXXFLAGS+= -DATF_SHELL='"/bin/sh"'
+
+ LDFLAGS+= -L${.OBJDIR}/../../../lib/atf/libatf-c++
+ LDFLAGS+= -L${.OBJDIR}/../../../lib/atf/libatf-c
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-pic.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-pic.patch
new file mode 100644
index 000000000000..22d5658394dd
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-pic.patch
@@ -0,0 +1,13 @@
+Fails to build on sparc without using -fPIC
+
+--- libexec/rtld-elf/Makefile.old 2010-01-09 17:17:21 +0100
++++ libexec/rtld-elf/Makefile 2010-01-09 17:17:33 +0100
+@@ -19,7 +19,7 @@
+ MLINKS= rtld.1 ld-elf.so.1.1 \
+ rtld.1 ld.so.1
+
+-CFLAGS+= -fpic -DPIC
++CFLAGS+= -fPIC -DPIC
+ LDFLAGS+= -shared -Wl,-Bsymbolic
+ DPADD= ${LIBC_PIC}
+ LDADD= -lc_pic
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-8.2-rtld.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-8.2-rtld.patch
new file mode 100644
index 000000000000..c60b2fec102c
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-8.2-rtld.patch
@@ -0,0 +1,40 @@
+--- head/libexec/rtld-elf/rtld.c 2011/09/15 11:50:09 225582
++++ head/libexec/rtld-elf/rtld.c 2011/10/08 12:39:47 226155
+@@ -495,8 +495,12 @@
+ exit (0);
+ }
+
+- /* setup TLS for main thread */
+- dbg("initializing initial thread local storage");
++ /*
++ * Processing tls relocations requires having the tls offsets
++ * initialized. Prepare offsets before starting initial
++ * relocation processing.
++ */
++ dbg("initializing initial thread local storage offsets");
+ STAILQ_FOREACH(entry, &list_main, link) {
+ /*
+ * Allocate all the initial objects out of the static TLS
+@@ -504,7 +508,6 @@
+ */
+ allocate_tls_offset(entry->obj);
+ }
+- allocate_initial_tls(obj_list);
+
+ if (relocate_objects(obj_main,
+ ld_bind_now != NULL && *ld_bind_now != '\0', &obj_rtld, NULL) == -1)
+@@ -519,6 +522,14 @@
+ exit (0);
+ }
+
++ /*
++ * Setup TLS for main thread. This must be done after the
++ * relocations are processed, since tls initialization section
++ * might be the subject for relocations.
++ */
++ dbg("initializing initial thread local storage");
++ allocate_initial_tls(obj_list);
++
+ dbg("initializing key program variables");
+ set_program_var("__progname", argv[0] != NULL ? basename(argv[0]) : "");
+ set_program_var("environ", env);
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch
new file mode 100644
index 000000000000..d33000927424
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch
@@ -0,0 +1,15 @@
+Use LD_* variables for 32bits too instead of the FreeBSD invention LD_32_*.
+We use LD_* everywhere on Gentoo and things like libtool wrappers have no clue
+about LD_32_* and thus fail to run from the build directory.
+
+diff -uNr libexec.old/rtld-elf/rtld.h libexec/rtld-elf/rtld.h
+--- libexec.old/rtld-elf/rtld.h 2013-08-24 12:30:26.000000000 -0400
++++ libexec/rtld-elf/rtld.h 2013-08-26 17:10:19.000000000 -0400
+@@ -47,7 +47,6 @@
+ #define _PATH_ELF_HINTS "/var/run/ld-elf32.so.hints"
+ /* For running 32 bit binaries */
+ #define STANDARD_LIBRARY_PATH "/lib32:/usr/lib32"
+-#define LD_ "LD_32_"
+ #endif
+
+ #ifndef STANDARD_LIBRARY_PATH
diff --git a/sys-freebsd/freebsd-libexec/files/ftpd.pamd b/sys-freebsd/freebsd-libexec/files/ftpd.pamd
new file mode 100644
index 000000000000..8e9082373f8f
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/ftpd.pamd
@@ -0,0 +1,8 @@
+# PAM configuration for the "ftpd" service
+#
+
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
+
diff --git a/sys-freebsd/freebsd-libexec/files/rquotad.xinetd b/sys-freebsd/freebsd-libexec/files/rquotad.xinetd
new file mode 100644
index 000000000000..876cd16c53c2
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/rquotad.xinetd
@@ -0,0 +1,11 @@
+service rquotad
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rquotad
+ rpc_version = 1
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-libexec/files/rstatd.xinetd b/sys-freebsd/freebsd-libexec/files/rstatd.xinetd
new file mode 100644
index 000000000000..ba1b819851eb
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/rstatd.xinetd
@@ -0,0 +1,11 @@
+service rstatd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rstatd
+ rpc_version = 1-3
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-libexec/files/rusersd.xinetd b/sys-freebsd/freebsd-libexec/files/rusersd.xinetd
new file mode 100644
index 000000000000..5cbe091881e8
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/rusersd.xinetd
@@ -0,0 +1,11 @@
+service rusersd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rusersd
+ rpc_version = 1-2
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-libexec/files/sprayd.xinetd b/sys-freebsd/freebsd-libexec/files/sprayd.xinetd
new file mode 100644
index 000000000000..7be55771ac22
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/sprayd.xinetd
@@ -0,0 +1,11 @@
+service sprayd
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.sprayd
+ rpc_version = 1
+ disabled = yes
+}
diff --git a/sys-freebsd/freebsd-libexec/files/walld.xinetd b/sys-freebsd/freebsd-libexec/files/walld.xinetd
new file mode 100644
index 000000000000..800b84fa21e6
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/walld.xinetd
@@ -0,0 +1,11 @@
+service walld
+{
+ type = rpc
+ socket_type = dgram
+ protocol = udp
+ wait = yes
+ user = root
+ server = /usr/libexec/rpc.rwalld
+ rpc_version = 1
+ disabled = yes
+}