summaryrefslogtreecommitdiff
path: root/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'sys-firmware/firmware-imx/firmware-imx-5.4.ebuild')
-rw-r--r--sys-firmware/firmware-imx/firmware-imx-5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
new file mode 100644
index 000000000000..ddd2096e89ce
--- /dev/null
+++ b/sys-firmware/firmware-imx/firmware-imx-5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="NXP i.MX firmware"
+HOMEPAGE="http://www.timesys.com/"
+SRC_URI="http://repository.timesys.com/buildsources/${PN:0:1}/${PN}/${P}/${P}.bin"
+LICENSE="LA_OPT_BASE_LICENSE"
+SLOT="0"
+KEYWORDS="~arm"
+
+S="${WORKDIR}/${P}/firmware"
+
+src_unpack() {
+ eval local $(grep -a -m1 "^filesizes=" "${DISTDIR}/${A}")
+ tail -c"${filesizes}" "${DISTDIR}/${A}" > "${P}.tar.bz2" || die
+ unpack "./${P}.tar.bz2"
+}
+
+src_prepare() {
+ default
+ find -name "*.mk" | xargs rm -v || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r epdc sdma vpu
+}