summaryrefslogtreecommitdiff
path: root/sys-devel/ucpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sys-devel/ucpp
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sys-devel/ucpp')
-rw-r--r--sys-devel/ucpp/Manifest2
-rw-r--r--sys-devel/ucpp/ucpp-1.3.5.ebuild9
2 files changed, 5 insertions, 6 deletions
diff --git a/sys-devel/ucpp/Manifest b/sys-devel/ucpp/Manifest
index 6a9351362e0e..61e97ff39dba 100644
--- a/sys-devel/ucpp/Manifest
+++ b/sys-devel/ucpp/Manifest
@@ -1,5 +1,5 @@
DIST ucpp-1.3.4.tar.xz 274488 BLAKE2B be43b8c88de2cd32514ecf7dc429c0ca5e88150594c9868fd6d8c3d90a0aabfc6e0f0741d75e4f558de426df7d6c54a3bc7e8e362c5066672f5fe9096cbedc18 SHA512 f9ea88e8f53e728a5b0fcb9084d6d6e140737b00fe350a9c6bc53ef2bb5f7b09d3c9d9a4a2147f635d796247e1b920fd3fea0cdce3ec3f4578694162c2f4c2a6
DIST ucpp-1.3.5.tar.xz 289468 BLAKE2B 6a038cc5d02f080747a321a55af66f2072503a5c0a554492ea8aed34ff9c3b7b85e3778114e18c3e09f06f1472a1479f39c96997404e0345153a1f84e3f9daee SHA512 3ded8f7bc2b238adb6e7f4162aee48e039dfe7cee31b700c38e8f147634d47cd1ceaf39c343549b0d4a58358e6b9743f7e84f87b253dc19c05e543d68ade24ce
EBUILD ucpp-1.3.4.ebuild 574 BLAKE2B 2002a1b0705e980708737550da4a722e8519ddf1c832a7decc7e7e898d66026e36bb24d0ed991b21e7f3fa12f968461e46756016372f56889ebccc4dfc837bd4 SHA512 2ba8452a39a918af48768c515f11510a8db1eab4881357625efba8349776e1b4a276e814dd78602b0c0e2f982a4d65d0a478220483600383e2a377a1e09b6fb1
-EBUILD ucpp-1.3.5.ebuild 620 BLAKE2B 68c704439b47439c0d511c67dd7ea75d1e1636190cee68c2d13422faf59fefb82b2a5fd9c7d33f73bd1ccbe8abbe364a86d849bf5574c75ebd543c0a41395ba9 SHA512 0a6d5b14542313bcc3661674f62bec34ce8a8e6321b863ccdfe43dc3189705e9acecc06c8e71d330f44b8797b6d2e9e705e74d6ddb6946d0f29368b40a3c5ae5
+EBUILD ucpp-1.3.5.ebuild 578 BLAKE2B ee28da66763c74804b8440604303ca5ade79b3020b5bba63d898504c26c9e6333dc915bfa6bff6aa4402eed9e0a364038c929c039b9cad170315fe3c674d41e5 SHA512 7b6813c5ffad2e9dc35af0bd9ebe76f554706092117869ab9268602bf9b7f0f9a00c48c20f6b5a9cb41385d8f828714a5fd0395f0f7796e826b4e07d414d1b30
MISC metadata.xml 450 BLAKE2B 0fba16b58542fffb8e1e99af14e6d4b1f24cd4d689e1a31e1cd513794f1f4c5c14eb7b4a39eab5e8c2a9d13433d670778171b6ac73be66e577798149a93db818 SHA512 6e19033ae2cbfe1a02e6fee2ed078600593e3cdbcccd4b86ec4ccb5283e3b3ad300d6bc9b9803b0b1f6a7e5cc49c8a0d955170e1fc7ba1f26ce0a26e3c0bdf48
diff --git a/sys-devel/ucpp/ucpp-1.3.5.ebuild b/sys-devel/ucpp/ucpp-1.3.5.ebuild
index dd47d3413428..858f87bb784f 100644
--- a/sys-devel/ucpp/ucpp-1.3.5.ebuild
+++ b/sys-devel/ucpp/ucpp-1.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,17 +10,16 @@ SRC_URI="https://gitlab.com/scarabeusiv/${PN}/uploads/79f08e39c676f15ed8a59335f6
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="static-libs"
src_configure() {
econf \
--disable-werror \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- # package provides .pc files
- find "${D}" -name '*.la' -type f -delete || die
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
}