summaryrefslogtreecommitdiff
path: root/sys-devel/qconf/qconf-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /sys-devel/qconf/qconf-2.4.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'sys-devel/qconf/qconf-2.4.ebuild')
-rw-r--r--sys-devel/qconf/qconf-2.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/qconf/qconf-2.4.ebuild b/sys-devel/qconf/qconf-2.4.ebuild
new file mode 100644
index 000000000000..8dd2ae4e5182
--- /dev/null
+++ b/sys-devel/qconf/qconf-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-plus/qconf"
+SRC_URI="http://psi-im.org/files/qconf/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not autotools configure. generates warnings for some autotools params.
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --qtdir="$(qt5_get_libdir)/qt5" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die "configure failed"
+
+ # just to set all the Gentoo toolchain flags
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ dodoc -r examples
+}