summaryrefslogtreecommitdiff
path: root/sys-devel/mold/mold-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 15:30:13 +0000
commit469b5d8f31adfd054c5c493fc3df2f9c89c9fa00 (patch)
treef51c77713647680335a341aeb6c5a7fa019a000b /sys-devel/mold/mold-9999.ebuild
parent7d6f532c36268a2a8f53fa33c8e547c59702faa6 (diff)
gentoo auto-resync : 11:11:2022 - 15:30:13
Diffstat (limited to 'sys-devel/mold/mold-9999.ebuild')
-rw-r--r--sys-devel/mold/mold-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 34d7e10e3bf1..45c7fd085eb8 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -12,20 +12,18 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
# mold (AGPL-3)
# - xxhash (BSD-2)
-# - tbb (Apache-2.0)
-LICENSE="AGPL-3 Apache-2.0 BSD-2"
+LICENSE="AGPL-3 BSD-2"
SLOT="0"
-IUSE="system-tbb"
RDEPEND="
app-arch/zstd:=
+ >=dev-cpp/tbb-2021.7.0:=
sys-libs/zlib
- system-tbb? ( >=dev-cpp/tbb-2021.4.0:= )
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
dev-libs/openssl:=
@@ -75,7 +73,7 @@ src_configure() {
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
-DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=$(usex system-tbb)
+ -DMOLD_USE_SYSTEM_TBB=ON
)
cmake_src_configure
}