summaryrefslogtreecommitdiff
path: root/sys-devel/mold/mold-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
commit6bf575618cf9022e99cbfcc64036fd9db79a749c (patch)
treef692d02fb905cd3d5bab465b790da48fb2de546b /sys-devel/mold/mold-2.4.0.ebuild
parent5944ce177026c93b7dab690db9d970567ddbf75f (diff)
gentoo auto-resync : 05:12:2023 - 17:02:58
Diffstat (limited to 'sys-devel/mold/mold-2.4.0.ebuild')
-rw-r--r--sys-devel/mold/mold-2.4.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-devel/mold/mold-2.4.0.ebuild b/sys-devel/mold/mold-2.4.0.ebuild
index d1954b0e0a9d..52d41ed470e9 100644
--- a/sys-devel/mold/mold-2.4.0.ebuild
+++ b/sys-devel/mold/mold-2.4.0.ebuild
@@ -93,3 +93,11 @@ src_install() {
dosym ${PN} /usr/bin/ld64.${PN}
dosym -r /usr/bin/${PN} /usr/libexec/${PN}/ld
}
+
+src_test() {
+ export TEST_CC="$(tc-getCC)" \
+ TEST_GCC="$(tc-getCC)" \
+ TEST_CXX="$(tc-getCXX)" \
+ TEST_GXX="$(tc-getCXX)"
+ cmake_src_test
+}