summaryrefslogtreecommitdiff
path: root/sys-devel/mold/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
commit8435c842b9e8fbb2bcc80397ab3aa655000459e2 (patch)
treeb74558e80643a8f074c501e8b4bf7f50f7155455 /sys-devel/mold/files
parent5c5e9714c851027611cb726a76ebb8be6d48cbdc (diff)
gentoo auto-resync : 03:07:2024 - 08:05:42
Diffstat (limited to 'sys-devel/mold/files')
-rw-r--r--sys-devel/mold/files/mold-2.32.1-libdl.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-2.32.1-libdl.patch b/sys-devel/mold/files/mold-2.32.1-libdl.patch
new file mode 100644
index 000000000000..994137938b68
--- /dev/null
+++ b/sys-devel/mold/files/mold-2.32.1-libdl.patch
@@ -0,0 +1,20 @@
+https://github.com/rui314/mold/commit/091395df335d577adc2a09e854a129f02081c576
+
+From 091395df335d577adc2a09e854a129f02081c576 Mon Sep 17 00:00:00 2001
+From: Rui Ueyama <ruiu@cs.stanford.edu>
+Date: Fri, 28 Jun 2024 11:00:36 +0900
+Subject: [PATCH] Link with `-ldl` for dlopen()
+
+Fixes https://github.com/rui314/mold/issues/1293
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,6 +61,8 @@ target_compile_features(mold PRIVATE cxx_std_20)
+
+ if(MINGW)
+ target_link_libraries(mold PRIVATE dl)
++else()
++ target_link_libraries(mold PRIVATE ${CMAKE_DL_LIBS})
+ endif()
+
+ if(NOT "${CMAKE_CXX_COMPILER_FRONTEND_VARIANT}" STREQUAL "MSVC")
+