summaryrefslogtreecommitdiff
path: root/sys-devel/mold/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
commit31459e63971ac3b08706bba949851d93c45043c3 (patch)
treef50f9db11363f1369a1aead733baccaf2842b673 /sys-devel/mold/files
parenteba9b95ba8976f2938bafa5789c1b50611bb3459 (diff)
gentoo auto-resync : 30:09:2022 - 15:24:40
Diffstat (limited to 'sys-devel/mold/files')
-rw-r--r--sys-devel/mold/files/mold-1.2.1-install-nopython.patch34
-rw-r--r--sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch28
-rw-r--r--sys-devel/mold/files/mold-1.3.1-fix-riscv-set32.patch25
3 files changed, 0 insertions, 87 deletions
diff --git a/sys-devel/mold/files/mold-1.2.1-install-nopython.patch b/sys-devel/mold/files/mold-1.2.1-install-nopython.patch
deleted file mode 100644
index 661d3dcf392f..000000000000
--- a/sys-devel/mold/files/mold-1.2.1-install-nopython.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 4fb6d4208cfb20bad4a3491a18e78409b5a8183f Mon Sep 17 00:00:00 2001
-From: Matthew Smith <matt@offtopica.uk>
-Date: Sat, 30 Apr 2022 07:42:50 +0100
-Subject: [PATCH] Don't invoke Python to create libexec/mold/ld symlink
-
-Reverts commits 8073a92614fb59f59570031badab5dd4bc3b4f7f and
-5803c3c200f301adc3abdb66df16d3d669712d70.
-
-Bug #841575
----
- Makefile | 7 +------
- 1 file changed, 1 insertion(+), 6 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index d1abc850..10e053a9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -204,12 +204,7 @@ install: all
- $(STRIP) $D$(LIBDIR)/mold/mold-wrapper.so
-
- $(INSTALL) -d $D$(LIBEXECDIR)/mold
--
--# We want to make a symblink with a relative path, so that users can
--# move the entire directory to other place without breaking the reference.
--# GNU ln supports `--relative` to do that, but that's not supported by
--# non-GNU systems. So we use Python to compute a relative path.
-- ln -sf `python3 -c "import os.path; print(os.path.relpath('$(BINDIR)/mold', '$(LIBEXECDIR)/mold'))"` $D$(LIBEXECDIR)/mold/ld
-+ ln -sf $(BINDIR)/mold $D$(LIBEXECDIR)/mold/ld
-
- $(INSTALL) -d $D$(MANDIR)/man1
- $(INSTALL_DATA) docs/mold.1 $D$(MANDIR)/man1
---
-2.35.3
-
diff --git a/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch b/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
deleted file mode 100644
index d2ed0af47b41..000000000000
--- a/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a4fde946f49cddf4f7c1eceb3b86ca38375cec1d Mon Sep 17 00:00:00 2001
-From: Matthew Smith <matt@offtopica.uk>
-Date: Sun, 26 Jun 2022 13:44:36 +0100
-Subject: [PATCH] Revert "Do not use pkg-config"
-
-This reverts commit 4ef90d4316bbba3a4b8902e38bf5f68171cc6ab7.
---- a/Makefile
-+++ b/Makefile
-@@ -18,6 +18,9 @@ ifeq ($(origin CXX), default)
- CXX = c++
- endif
-
-+# Allow overriding pkg-config binary
-+PKG_CONFIG = pkg-config
-+
- # If you want to keep symbols in the installed binary, run make with
- # `STRIP=true` to run /bin/true instead of the strip command.
- STRIP = strip
-@@ -100,7 +103,8 @@ ifeq ($(OS), Darwin)
- endif
-
- ifeq ($(NEEDS_LIBCRYPTO), 1)
-- MOLD_LDFLAGS += -lcrypto
-+ MOLD_CXXFLAGS += $(shell $(PKG_CONFIG) --cflags-only-I openssl)
-+ MOLD_LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L openssl) -lcrypto
- endif
-
- # '-latomic' flag is needed building on riscv64 system.
diff --git a/sys-devel/mold/files/mold-1.3.1-fix-riscv-set32.patch b/sys-devel/mold/files/mold-1.3.1-fix-riscv-set32.patch
deleted file mode 100644
index 5613d8ddc003..000000000000
--- a/sys-devel/mold/files/mold-1.3.1-fix-riscv-set32.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From https://github.com/rui314/mold/pull/590
-From 68bd00caa7c7946f380f72a5dd263e7c1d436e9f Mon Sep 17 00:00:00 2001
-From: Alex Fan <alex.fan.q@gmail.com>
-Date: Thu, 28 Jul 2022 14:04:21 +1000
-Subject: [PATCH] [ELF][RISCV] add missing R_RISCV_SET32 in EhFrameSection
-
-Signed-off-by: Alex Fan <alex.fan.q@gmail.com>
----
- elf/arch-riscv64.cc | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/elf/arch-riscv64.cc b/elf/arch-riscv64.cc
-index 8761c6ac..0c589118 100644
---- a/elf/arch-riscv64.cc
-+++ b/elf/arch-riscv64.cc
-@@ -183,6 +183,9 @@ void EhFrameSection<E>::apply_reloc(Context<E> &ctx, const ElfRel<E> &rel,
- case R_RISCV_SET16:
- *(ul16 *)loc = val;
- return;
-+ case R_RISCV_SET32:
-+ *(ul32 *)loc = val;
-+ return;
- case R_RISCV_32_PCREL:
- *(ul32 *)loc = val - this->shdr.sh_addr - offset;
- return;