summaryrefslogtreecommitdiff
path: root/sys-devel/make/make-4.2.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-devel/make/make-4.2.1-r4.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-devel/make/make-4.2.1-r4.ebuild')
-rw-r--r--sys-devel/make/make-4.2.1-r4.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-devel/make/make-4.2.1-r4.ebuild b/sys-devel/make/make-4.2.1-r4.ebuild
deleted file mode 100644
index d5fead12467a..000000000000
--- a/sys-devel/make/make-4.2.1-r4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
- "${FILESDIR}"/${PN}-4.2-default-cxx.patch
- "${FILESDIR}"/${PN}-4.2.1-perl526.patch
- "${FILESDIR}"/${PN}-4.2.1-glob-internals.patch
- "${FILESDIR}"/${PN}-4.2.1-pselect-non-blocking.patch
-)
-
-src_prepare() {
- default
- # These patches require special handling as they modify configure.ac
- # which in turn triggers maintainer-mode when being applied the
- # usual way.
- eapply -Z "${FILESDIR}"/${PN}-4.2.1-glob-v2.patch \
- "${FILESDIR}"/${P}-guile-2.2.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --program-prefix=g
- $(use_with guile)
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}