summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
commita5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (patch)
tree3d2e0a61f348a5299e73ca7c2b236156a8cc79b5 /sys-devel/llvm/llvm-4.0.1.ebuild
parent38f60b3ec9ff175535d9a056a76ae42931e61e21 (diff)
gentoo resync : 18.11.2017
Diffstat (limited to 'sys-devel/llvm/llvm-4.0.1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-4.0.1.ebuild10
1 files changed, 0 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-4.0.1.ebuild b/sys-devel/llvm/llvm-4.0.1.ebuild
index 4e3e2dcbed0e..6eca3552280d 100644
--- a/sys-devel/llvm/llvm-4.0.1.ebuild
+++ b/sys-devel/llvm/llvm-4.0.1.ebuild
@@ -53,7 +53,6 @@ DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )
- test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
# There are no file collisions between these versions but having :0
@@ -71,11 +70,6 @@ S=${WORKDIR}/${P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
@@ -133,10 +127,6 @@ multilib_src_configure() {
)
# fi
- use test && mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
- )
-
if multilib_is_native_abi; then
mycmakeargs+=(
-DLLVM_BUILD_DOCS=$(usex doc)