summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-3.4.2-r100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
commit8fcdcec5fbdd0e3a77391e4f354218014f59f358 (patch)
treeb6aaf9c103052f2ab4a948377142f4a4233caa60 /sys-devel/llvm/llvm-3.4.2-r100.ebuild
parent423d21dcfee183cc4b04d29c1621615e8c30f834 (diff)
gentoo resync : 05.01.2018
Diffstat (limited to 'sys-devel/llvm/llvm-3.4.2-r100.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index c533ef6f68e8..430d90928c05 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,7 +13,8 @@ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.gz
clang? ( https://llvm.org/releases/3.4/compiler-rt-3.4.src.tar.gz
https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.gz )
https://dev.gentoo.org/~mgorny/dist/llvm/${PN}-3.4-manpages.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
+ https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/${PN}-3.4-patchset-darwin-leopard.tar.gz"
# Additional licenses:
# 1. OpenBSD regex: Henry Spencer's license ('rc' in Gentoo) + BSD.
@@ -105,6 +106,11 @@ src_prepare() {
epatch "${WORKDIR}/${P}-patchset"/clang/gentoo-runtime-gcc-detection-v3.patch
epatch "${WORKDIR}/${P}-patchset"/clang/gentoo-install.patch
+
+ if [[ ${CHOST} == *-darwin8 ]] || [[ ${CHOST} == *-darwin9 ]] ; then
+ EPATCH_SOURCE="${WORKDIR}"/${PN}-3.4-patchset-darwin-leopard \
+ EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
+ fi
epatch "${WORKDIR}/${P}-patchset"/clang/darwin_build_fix.patch
epatch "${WORKDIR}/${P}-patchset"/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp