summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-19.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
commit31a02d889028bf30f7b376b935aa05c2140d3c66 (patch)
tree6b211d58d5072baba31037fda71f6f421c38e5c8 /sys-devel/llvm/llvm-19.0.0.9999.ebuild
parent8f53b8011f9c960a02775a71c3805e13e72237fd (diff)
gentoo auto-resync : 08:02:2024 - 09:59:13
Diffstat (limited to 'sys-devel/llvm/llvm-19.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-19.0.0.9999.ebuild10
1 files changed, 0 insertions, 10 deletions
diff --git a/sys-devel/llvm/llvm-19.0.0.9999.ebuild b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
index 23646ea90d8a..8ff126c7d4a1 100644
--- a/sys-devel/llvm/llvm-19.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-19.0.0.9999.ebuild
@@ -446,16 +446,6 @@ multilib_src_configure() {
-DTerminfo_LIBRARIES=-lncurses
)
- # workaround BMI bug in gcc-7 (fixed in 7.4)
- # https://bugs.gentoo.org/649880
- # apply only to x86, https://bugs.gentoo.org/650506
- if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
- [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
- then
- local CFLAGS="${CFLAGS} -mno-bmi"
- local CXXFLAGS="${CXXFLAGS} -mno-bmi"
- fi
-
# LLVM can have very high memory consumption while linking,
# exhausting the limit on 32-bit linker executable
use x86 && local -x LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"