summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-18.1.0_rc3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 05:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 05:43:10 +0000
commit57e2174dcd454b41778b7b437f88d0a9f1a6e428 (patch)
treee6f528c74cef8bdfdf1b07fbba3a70acbae6af25 /sys-devel/llvm/llvm-18.1.0_rc3.ebuild
parent0a648c5255c22a6092b8de20ffba9e235299a293 (diff)
gentoo auto-resync : 04:03:2024 - 05:43:09
Diffstat (limited to 'sys-devel/llvm/llvm-18.1.0_rc3.ebuild')
-rw-r--r--sys-devel/llvm/llvm-18.1.0_rc3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-18.1.0_rc3.ebuild b/sys-devel/llvm/llvm-18.1.0_rc3.ebuild
index 55ced7c14db1..5031f93dd455 100644
--- a/sys-devel/llvm/llvm-18.1.0_rc3.ebuild
+++ b/sys-devel/llvm/llvm-18.1.0_rc3.ebuild
@@ -444,11 +444,13 @@ multilib_src_configure() {
)
fi
- # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
- # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
- # using libtinfo (actually, libncurses.dylib) from system instead of prefix
use kernel_Darwin && mycmakeargs+=(
+ # On Macos prefix, Gentoo doesn't split sys-libs/ncurses to libtinfo and
+ # libncurses, but llvm tries to use libtinfo before libncurses, and ends up
+ # using libtinfo (actually, libncurses.dylib) from system instead of prefix
-DTerminfo_LIBRARIES=-lncurses
+ # Use our libtool instead of looking it up with xcrun
+ -DCMAKE_LIBTOOL="${EPREFIX}/usr/bin/${CHOST}-libtool"
)
# LLVM can have very high memory consumption while linking,