summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-17.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 22:05:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 22:05:15 +0100
commitaffa75f527bf2512b296482bd14bade15f820d6a (patch)
treeccad15ef56fd6e66c5f1a0af604048c4a3728828 /sys-devel/llvm/llvm-17.0.0.9999.ebuild
parentbbeceee79ae8bdf53d0a494f86896a356e1cfe5f (diff)
gentoo auto-resync : 15:05:2023 - 22:05:14
Diffstat (limited to 'sys-devel/llvm/llvm-17.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-17.0.0.9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sys-devel/llvm/llvm-17.0.0.9999.ebuild b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
index 1ae16d3ef49a..c2c2d7c6b628 100644
--- a/sys-devel/llvm/llvm-17.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-17.0.0.9999.ebuild
@@ -4,8 +4,9 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs flag-o-matic
+
+inherit cmake llvm.org multilib-minimal pax-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -338,8 +339,6 @@ get_distribution_components() {
}
multilib_src_configure() {
- tc-is-gcc && filter-lto # GCC miscompiles LLVM, bug #873670
-
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)