summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-14.0.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 20:29:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 20:29:22 +0000
commit71fb24e4cc15fe73651423df81c5e6a79fa8c142 (patch)
tree962fbc79d3fbda0c4123d5119df5e728d4d7b18c /sys-devel/llvm/llvm-14.0.6-r2.ebuild
parentaae71b4d8e684ca22d28ef0f1da0989e7bf6468d (diff)
gentoo auto-resync : 22:02:2023 - 20:29:22
Diffstat (limited to 'sys-devel/llvm/llvm-14.0.6-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-14.0.6-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-14.0.6-r2.ebuild b/sys-devel/llvm/llvm-14.0.6-r2.ebuild
index 4c18c1ba4aa7..dc3a35b256f4 100644
--- a/sys-devel/llvm/llvm-14.0.6-r2.ebuild
+++ b/sys-devel/llvm/llvm-14.0.6-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
- toolchain-funcs
+ toolchain-funcs flag-o-matic
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -321,12 +321,13 @@ get_distribution_components() {
}
multilib_src_configure() {
+ tcc-is-gcc && filter-lto # GCC miscompiles LLVM, bug #873670
+
local ffi_cflags ffi_ldflags
if use libffi; then
ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)
ffi_ldflags=$($(tc-getPKG_CONFIG) --libs-only-L libffi)
fi
-
local libdir=$(get_libdir)
local mycmakeargs=(
# disable appending VCS revision to the version to improve