summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /sys-devel/llvm-common
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/Manifest1
-rw-r--r--sys-devel/llvm-common/llvm-common-8.0.9999.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/Manifest b/sys-devel/llvm-common/Manifest
index 7bac66c909cf..6f25d774c50c 100644
--- a/sys-devel/llvm-common/Manifest
+++ b/sys-devel/llvm-common/Manifest
@@ -7,5 +7,6 @@ EBUILD llvm-common-5.0.2.ebuild 839 BLAKE2B d7e6aaba7df7b7da6da5f7cc9cc165b89217
EBUILD llvm-common-6.0.1.ebuild 838 BLAKE2B 7c30c7e7e52916af34728e11cc6e00e6add5363974affd53e7940bcbacfb3b7a73bd17d86b29b10684535ced07c0237909473c4500e2439d5824b4cbcf924d7e SHA512 d642ce674d3a0a742e5afaeb97a5e67e5a616ddd18642777dc640c44fc65c9f5d34c5e1398483c062152e87c9ab076b5518ad3ab5d39df9d1ce1331eb2784464
EBUILD llvm-common-7.0.1.ebuild 839 BLAKE2B cf53a218b327891d8647c5c703470b85f28d60bd36057d9eff6273746af7da0ff6ec8f09589a19c6df46f89359c663cbbca8898082f33a6a58baacce883e1469 SHA512 c02493f7f293c9b500a2e5a68d065053b61ec22f9d1e082e6cf802b869f0097ba2ffb04a7db65dd8441bafc6555c16a4cf6868ab3ce3a3ddd562c92f011dae48
EBUILD llvm-common-7.0.9999.ebuild 729 BLAKE2B da80aa6feb2e836dc2549dac86659c920be0b8430a70c322d7337a5771963d2cff95d497486904a5e96706002123c098ba446a50925269122c14abdb8cdae76e SHA512 b45c99bc3f1c5ec05df418b2206245159b5604c6780e497f16ce52f50def0d0e867151ee7f6811b5ac72150336f0821dc1c4e56ed1e9302d840dd23b6a651a26
+EBUILD llvm-common-8.0.9999.ebuild 726 BLAKE2B dc1acf8df7298c6a658b6b4c9d11335363c2e8be2c437e414a7379c104ee8300f52375c1c20e441edf397558b73e5e37099ad421ef43869625dc79e58c85e165 SHA512 cb7c4c44f573c2b4918fb40e2db5d92937ec6079e68ae832a4419382487996ddca833655beb3a1e0b433d69ae96649995d77890d4c2f88b010f3d613c8168dc8
EBUILD llvm-common-9999.ebuild 704 BLAKE2B bfcd46a0c3754d0c5542eb1b03c8696ef355ebe34e94c98ab6a23442a88bc6b9a8aa8d2c89b18ed0ceea47bd2adcd7df67c8d201876a04ba7816257f83c53706 SHA512 4a7fd7260e93fa3b44a565c915a8be2e207085a506018b97263740851fd78dacf88e582b73d74a06aa36de2975b751c258ceb7997a5e6ee7db4d404fbed865bf
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild
new file mode 100644
index 000000000000..d83ddbc253e5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-8.0.9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/vim
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}