summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
commita597364520b9291d0b2a23bb007ced022e821d95 (patch)
treefbdb29d309a73a184394006e206a8d4362ccdad8 /sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild
parent1def2e3dbbf3c86abad238d1118502cfe7f61f08 (diff)
gentoo auto-resync : 20:08:2023 - 15:41:38
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild b/sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild
new file mode 100644
index 000000000000..ce5f03ca34a5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-18.0.0_pre20230820.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}