summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-16.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-18 10:12:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-18 10:12:16 +0100
commit8ea6e43d2f65acbfda614dbd4635823d7605b6d8 (patch)
tree06f832bd17f7282b5cd87dbec9f023e550afcc04 /sys-devel/llvm-common/llvm-common-16.0.4.ebuild
parent75b7b7da41881995754ded71c9c029cb1686096d (diff)
gentoo auto-resync : 18:05:2023 - 10:12:16
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-16.0.4.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-16.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-16.0.4.ebuild b/sys-devel/llvm-common/llvm-common-16.0.4.ebuild
new file mode 100644
index 000000000000..4dd4fe395fe7
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-16.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}