summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-15.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 17:24:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 17:24:07 +0100
commit800c4c398cad9dd837da33062e71ccc84114fe05 (patch)
tree9016107a696d96ddfaea5f7fa6d55eadc54d4987 /sys-devel/llvm-common/llvm-common-15.0.1.ebuild
parentc17e7d2a8cc12551a02d28209cd2edbf078d5675 (diff)
gentoo auto-resync : 20:09:2022 - 17:24:07
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-15.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.1.ebuild b/sys-devel/llvm-common/llvm-common-15.0.1.ebuild
new file mode 100644
index 000000000000..104c8747bbee
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-15.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}