summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-14.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
commitb6a0f46f7d2e1e21df70fb32169f7d9de85445f7 (patch)
tree2f1b6f7c25e85d70d737cd66c68673ed58e1108e /sys-devel/llvm-common/llvm-common-14.0.6.ebuild
parent9173f73d44f3cbc858477bd71e7680ede7d98e0d (diff)
gentoo auto-resync : 22:12:2023 - 19:52:05
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-14.0.6.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-14.0.6.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-devel/llvm-common/llvm-common-14.0.6.ebuild b/sys-devel/llvm-common/llvm-common-14.0.6.ebuild
deleted file mode 100644
index c8fdea852737..000000000000
--- a/sys-devel/llvm-common/llvm-common-14.0.6.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common llvm.org
-
-DESCRIPTION="Common files shared between multiple slots of LLVM"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
-IUSE="emacs"
-
-RDEPEND="
- !sys-devel/llvm:0
-"
-BDEPEND="
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-
-LLVM_COMPONENTS=( llvm/utils )
-llvm.org_set_globals
-
-SITEFILE="50llvm-gentoo.el"
-BYTECOMPFLAGS="-L emacs"
-
-src_compile() {
- default
-
- use emacs && elisp-compile emacs/*.el
-}
-
-src_install() {
- insinto /usr/share/vim/vimfiles
- doins -r vim/*/
- # some users may find it useful
- newdoc vim/README README.vim
- dodoc vim/vimrc
-
- if use emacs ; then
- elisp-install llvm emacs/*.{el,elc}
- elisp-make-site-file "${SITEFILE}" llvm
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}