summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-14.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /sys-devel/llvm-common/llvm-common-14.0.1.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-14.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-14.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-14.0.1.ebuild b/sys-devel/llvm-common/llvm-common-14.0.1.ebuild
new file mode 100644
index 000000000000..3b5304a686ce
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-14.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}