summaryrefslogtreecommitdiff
path: root/sys-devel/libtool/libtool-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /sys-devel/libtool/libtool-9999.ebuild
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'sys-devel/libtool/libtool-9999.ebuild')
-rw-r--r--sys-devel/libtool/libtool-9999.ebuild34
1 files changed, 23 insertions, 11 deletions
diff --git a/sys-devel/libtool/libtool-9999.ebuild b/sys-devel/libtool/libtool-9999.ebuild
index 13af7fa0f519..140bf7a5cb41 100644
--- a/sys-devel/libtool/libtool-9999.ebuild
+++ b/sys-devel/libtool/libtool-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
LIBTOOLIZE="true" #225559
WANT_LIBTOOL="none"
-inherit autotools epatch epunt-cxx multilib unpacker prefix
+inherit autotools epunt-cxx multilib unpacker prefix
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
@@ -33,23 +33,35 @@ DEPEND="${RDEPEND}
app-arch/xz-utils"
[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
+ "${FILESDIR}"/${PN}-2.4.6-mint.patch
+ "${FILESDIR}"/${PN}-2.2.6a-darwin-module-bundle.patch
+ "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
+)
+
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
- cd "${S}"
- ./bootstrap || die
else
unpacker_src_unpack
fi
}
src_prepare() {
+ if [[ "${PV}" = 9999 ]] ; then
+ eapply "${FILESDIR}"/${PN}-2.4.6-pthread.patch #650876
+ ./bootstrap || die
+ else
+ PATCHES+=(
+ "${FILESDIR}"/${P}-pthread_bootstrapped.patch #650876
+ )
+ fi
+
use vanilla && return 0
- epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
- epatch "${FILESDIR}"/${PN}-2.4.6-mint.patch
- epatch "${FILESDIR}"/${PN}-2.2.6a-darwin-module-bundle.patch
- epatch "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
+ default
+
if use prefix ; then
# seems that libtool has to know about EPREFIX a little bit
# better, since it fails to find prefix paths to search libs
@@ -58,7 +70,7 @@ src_prepare() {
# (argh...). This could also be fixed by making the gcc wrapper
# return the correct result for -print-search-dirs (doesn't
# include prefix dirs ...).
- epatch "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
+ eapply "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
eprefixify m4/libtool.m4
fi
pushd libltdl >/dev/null
@@ -79,10 +91,10 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=$(type -P bash)
+ export CONFIG_SHELL="$(type -P bash)"
# Do not bother hardcoding the full path to sed. Just rely on $PATH. #574550
- export ac_cv_path_SED=$(basename "$(type -P sed)")
+ export ac_cv_path_SED="$(basename "$(type -P sed)")"
local myconf
[[ ${CHOST} == *-darwin* ]] && myconf="--program-prefix=g"