summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-05 00:00:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-05 00:00:45 +0100
commitb594445f39d99066071d80fc8efeba5c8f72cc35 (patch)
tree9bf469821b12ac103807e30a6f7751d955648125 /sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild
parent7f3fecbb5b871825fe9632f46659869cab6a3769 (diff)
gentoo auto-resync : 05:05:2024 - 00:00:45
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild b/sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild
new file mode 100644
index 000000000000..1105de63f8d0
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-11.4.1_p20240501.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+
+GCC_TARGET_NO_MULTILIB=true
+TOOLCHAIN_ALLOWED_LANGS="c"
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_GCC_VER="11.4.0"
+PATCH_VER="12"
+MUSL_VER="2"
+MUSL_GCC_VER="11.4.0"
+PYTHON_COMPAT=( python3_{10..11} )
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+BDEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}