summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-03 22:54:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-03 22:54:31 +0100
commitb0ebd12de22226fd7b69140ccd700efda3eb5fa6 (patch)
treeefcf8d59607e53b8bf2fb453629b05bea28cc3ce /sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild
parent99547b97ff461f107e03ed5323b6286a66677bce (diff)
gentoo auto-resync : 03:08:2023 - 22:54:30
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild b/sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild
new file mode 100644
index 000000000000..1b674fb17f78
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-11.4.1_p20230622.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+
+GCC_TARGET_NO_MULTILIB=true
+TOOLCHAIN_ALLOWED_LANGS="c"
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_GCC_VER="11.4.0"
+PATCH_VER="10"
+MUSL_VER="2"
+MUSL_GCC_VER="11.4.0"
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+BDEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}