summaryrefslogtreecommitdiff
path: root/sys-devel/gnuconfig/gnuconfig-20221007.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /sys-devel/gnuconfig/gnuconfig-20221007.ebuild
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'sys-devel/gnuconfig/gnuconfig-20221007.ebuild')
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20221007.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-devel/gnuconfig/gnuconfig-20221007.ebuild b/sys-devel/gnuconfig/gnuconfig-20221007.ebuild
deleted file mode 100644
index 344e27cd9ff9..000000000000
--- a/sys-devel/gnuconfig/gnuconfig-20221007.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == 99999999 ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/r/config.git"
-
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- S="${WORKDIR}"
-fi
-
-DESCRIPTION="Updated config.sub and config.guess file from GNU"
-HOMEPAGE="https://savannah.gnu.org/projects/config"
-
-LICENSE="GPL-3+-with-autoconf-exception"
-SLOT="0"
-
-maint_pkg_create() {
- cd "${S}" || die
-
- emake ChangeLog
- local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
- [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
-
- local tar="${T}/gnuconfig-${ver}.tar.xz"
- tar -Jcf "${tar}" ./* || die "creating tar failed"
- einfo "Packaged tar now available:"
- einfo "$(du -b "${tar}")"
-}
-
-src_unpack() {
- if [[ ${PV} == 99999999 ]] ; then
- git-r3_src_unpack
- maint_pkg_create
- else
- unpack ${A}
- fi
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins config.{sub,guess}
- fperms +x /usr/share/${PN}/config.{sub,guess}
- dodoc ChangeLog
-}