summaryrefslogtreecommitdiff
path: root/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /sys-devel/gnuconfig/gnuconfig-20220508.ebuild
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'sys-devel/gnuconfig/gnuconfig-20220508.ebuild')
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20220508.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-devel/gnuconfig/gnuconfig-20220508.ebuild b/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
deleted file mode 100644
index 1d1a7649fea0..000000000000
--- a/sys-devel/gnuconfig/gnuconfig-20220508.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-if [[ ${PV} == 99999999 ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/r/config.git"
-
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
- S="${WORKDIR}"
-fi
-
-DESCRIPTION="Updated config.sub and config.guess file from GNU"
-HOMEPAGE="https://savannah.gnu.org/projects/config"
-
-LICENSE="GPL-3+-with-autoconf-exception"
-SLOT="0"
-
-maint_pkg_create() {
- cd "${S}" || die
-
- emake ChangeLog
- local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
- [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
-
- cp "${FILESDIR}"/${PV}/*.patch . || die
-
- local tar="${T}/gnuconfig-${ver}.tar.xz"
- tar -Jcf "${tar}" ./* || die "creating tar failed"
- einfo "Packaged tar now available:"
- einfo "$(du -b "${tar}")"
-}
-
-src_unpack() {
- if [[ ${PV} == 99999999 ]] ; then
- git-r3_src_unpack
- maint_pkg_create
- else
- unpack ${A}
- fi
-}
-
-src_prepare() {
- default
-
- eapply "${S}"/*.patch
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins config.{sub,guess}
- fperms +x /usr/share/${PN}/config.{sub,guess}
- dodoc ChangeLog
-}