summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-devel/gdb/gdb-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index ada72ec65c4d..4805e0131ff3 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit eutils flag-o-matic python-single-r1 toolchain-funcs
@@ -100,6 +100,7 @@ src_prepare() {
default
strip-linguas -u bfd/po opcodes/po
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
}
gdb_branding() {
@@ -136,7 +137,7 @@ src_configure() {
if use server && ! use client ; then
# just configure+build in the gdbserver subdir to speed things up
- cd gdb/gdbserver
+ cd gdbserver
myconf+=( --program-transform-name='' )
else
# gdbserver only works for native targets (CHOST==CTARGET).
@@ -157,6 +158,7 @@ src_configure() {
--disable-install-libiberty
# Disable guile for now as it requires guile-2.x #562902
--without-guile
+ --enable-obsolete
# This only disables building in the readline subdir.
# For gdb itself, it'll use the system version.
--disable-readline
@@ -189,13 +191,12 @@ src_configure() {
src_install() {
if use server && ! use client; then
- cd gdb/gdbserver || die
+ cd gdbserver || die
fi
default
if use client; then
find "${ED}"/usr -name libiberty.a -delete || die
fi
- cd "${S}" || die
# Delete translations that conflict with binutils-libs. #528088
# Note: Should figure out how to store these in an internal gdb dir.
@@ -220,7 +221,7 @@ src_install() {
# https://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
# Only install if it exists due to the twisted behavior (see
# notes in src_configure above).
- [[ -e gdb/gdbserver/gdbreplay ]] && dobin gdb/gdbserver/gdbreplay
+ [[ -e gdbserver/gdbreplay ]] && dobin gdbserver/gdbreplay
if use client ; then
docinto gdb
@@ -231,7 +232,7 @@ src_install() {
dodoc sim/{ChangeLog,MAINTAINERS,README-HACKING}
if use server ; then
docinto gdbserver
- dodoc gdb/gdbserver/{ChangeLog,README}
+ dodoc gdbserver/{ChangeLog,README}
fi
if [[ -n ${PATCH_VER} ]] ; then