summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
commit5ae7efc9abae6bb8f8fac438298427769a91f5ad (patch)
treedc25abd0d9e2475f76b5060721ab492d2958a45f /sys-devel/gdb/gdb-9999.ebuild
parent2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (diff)
gentoo auto-resync : 04:03:2023 - 07:37:01
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index d356d5e3ecab..bc86849c6276 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -160,21 +160,13 @@ src_configure() {
# But the check does not quite work on i686: bug #760926.
$(use_enable cet)
- # We need to set both configure options, --with-sysroot and --libdir,
- # to fix cross build issues that happen when configuring gmp.
- # We explicitly need --libdir. Having only --with-sysroot without
- # --libdir would not fix the build issues.
- # For some reason, it is not enough to set only --with-sysroot,
- # also not enough to pass --with-gmp-xxx options.
- --with-sysroot="${ESYSROOT}"
- --libdir="${ESYSROOT}/usr/$(get_libdir)"
+ # Helps when cross-compiling. Not to be confused with --with-sysroot.
+ --with-build-sysroot="${ESYSROOT}"
)
- local sysroot="${EPREFIX}/usr/${CTARGET}"
-
is_cross && myconf+=(
- --with-sysroot="${sysroot}"
- --includedir="${sysroot}/usr/include"
+ --with-sysroot="\${prefix}/${CTARGET}"
+ --includedir="\${prefix}/include/${CTARGET}"
--with-gdb-datadir="\${datadir}/gdb/${CTARGET}"
)
@@ -211,6 +203,13 @@ src_configure() {
$(use_with xxhash)
$(use_with guile)
$(use_with zstd)
+
+ # Find libraries using the toolchain sysroot rather than the configured
+ # prefix. Needed when cross-compiling.
+ #
+ # Check which libraries to apply this to with:
+ # "${S}"/gdb/configure --help | grep without-lib | sort
+ --without-lib{babeltrace,expat,gmp,iconv,ipt,lzma,mpfr,xxhash}-prefix
)
if use sparc-solaris || use x86-solaris ; then