summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-26 07:55:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-26 07:55:33 +0000
commit220317eb99d11e6c68af921f2855409bc506461a (patch)
tree2396ba62744fce46eb3116a569d83b54f0a36fc3 /sys-devel/gdb/gdb-9999.ebuild
parent79de60c14eee653ca1a344ce0f850edc088f1bc8 (diff)
gentoo auto-resync : 26:01:2023 - 07:55:33
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild37
1 files changed, 20 insertions, 17 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 5a1837450675..a79f0ab1957d 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -41,11 +41,15 @@ case ${PV} in
;;
esac
+PATCH_DEV=""
+PATCH_VER=""
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}"
+SRC_URI="
+ ${SRC_URI}
+ ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
+"
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
@@ -58,16 +62,7 @@ fi
IUSE="cet guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# In fact, gdb's test suite needs some work to get passing.
-# See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
-# As of 11.2, on amd64: "# of unexpected failures 8600"
-# Also, ia64 kernel crashes when gdb testsuite is running.
-RESTRICT="
- ia64? ( test )
- !test? ( test )
- test
-"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/mpfr:0=
@@ -233,6 +228,18 @@ src_compile() {
emake V=1
}
+src_test() {
+ # Run the unittests (nabbed invocation from Fedora's spec file) at least
+ emake -k -C gdb run GDBFLAGS='-batch -ex "maintenance selftest"'
+
+ # Too many failures
+ # In fact, gdb's test suite needs some work to get passing.
+ # See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
+ # As of 11.2, on amd64: "# of unexpected failures 8600"
+ # Also, ia64 kernel crashes when gdb testsuite is running.
+ #emake -k check
+}
+
src_install() {
emake V=1 DESTDIR="${D}" install
@@ -275,10 +282,6 @@ src_install() {
dodoc gdbserver/README
fi
- if [[ -n ${PATCH_VER} ]] ; then
- dodoc "${WORKDIR}"/extra/gdbinit.sample
- fi
-
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,ctf-spec,standards}.info*