summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
commit0b82ae29b3034efe3e7b7f533dbcb76168544c5e (patch)
treeea954d341afdcf53b3b79c78c9a54ff2c9693096 /sys-devel/gdb/gdb-9999.ebuild
parentb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (diff)
gentoo auto-resync : 25:03:2023 - 06:49:35
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index bc86849c6276..c88c3a08b21c 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -34,6 +34,11 @@ case ${PV} in
https://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${MY_PV}.tar.xz
"
S="${WORKDIR}/${PN}-${MY_PV}"
+
+ # e.g. 13.1.90_p20230325 is a snapshot on the stable branch, so it's fine
+ if [[ ${PV} == *.[123456789].9?_p2??????? ]] ; then
+ REGULAR_RELEASE=1
+ fi
;;
*.*.9?)
# Prereleases
@@ -50,8 +55,7 @@ case ${PV} in
https://sourceware.org/pub/gdb/releases/${P}.tar.xz
"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- ;;
+ REGULAR_RELEASE=1
esac
PATCH_DEV=""
@@ -67,14 +71,17 @@ SRC_URI="
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
IUSE="cet guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
+if [[ -n ${REGULAR_RELEASE} ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-libs/mpfr:0=
+ dev-libs/mpfr:=
dev-libs/gmp:=
- >=sys-libs/ncurses-5.2-r2:0=
- >=sys-libs/readline-7:0=
+ >=sys-libs/ncurses-5.2-r2:=
+ >=sys-libs/readline-7:=
sys-libs/zlib
elibc_glibc? ( net-libs/libnsl:= )
lzma? ( app-arch/xz-utils )