summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /sys-devel/gdb/files
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'sys-devel/gdb/files')
-rw-r--r--sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch19
-rw-r--r--sys-devel/gdb/files/gdb-8.3.50.20190312-source-highlight.patch136
2 files changed, 155 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch b/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch
new file mode 100644
index 000000000000..c134cbcae8df
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-8.3.50.20190312-c++17.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/680232
+
+--- a/gdb/unittests/string_view-selftests.c
++++ b/gdb/unittests/string_view-selftests.c
+@@ -170,10 +170,12 @@ run_tests ()
+ } /* namespace string_view */
+ } /* namespace selftests */
+
++#endif /* __cplusplus < 201703L */
++
+ void
+ _initialize_string_view_selftests ()
+ {
++#if defined(GDB_STRING_VIEW)
+ selftests::register_test ("string_view", selftests::string_view::run_tests);
++#endif
+ }
+-
+-#endif /* __cplusplus < 201703L */
diff --git a/sys-devel/gdb/files/gdb-8.3.50.20190312-source-highlight.patch b/sys-devel/gdb/files/gdb-8.3.50.20190312-source-highlight.patch
new file mode 100644
index 000000000000..6479efe572f4
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-8.3.50.20190312-source-highlight.patch
@@ -0,0 +1,136 @@
+From d46304c605ff119bc6bae38b7841d64e7568b691 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Wed, 13 Mar 2019 21:15:13 +0000
+Subject: [PATCH] gdb/configure.ac: add --enable-source-highlight
+
+Allow disabling source-highlight dependency autodetection even
+it exists in the system. More details on problem of automatic
+dependencies:
+https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Automagic_dependencies
+
+Noticed by Jeroen Roovers in https://bugs.gentoo.org/680238
+--- a/gdb/configure
++++ b/gdb/configure
+@@ -879,6 +879,7 @@ with_mpfr
+ with_libmpfr_prefix
+ with_python
+ with_guile
++enable_source_highlight
+ enable_libmcheck
+ with_intel_pt
+ with_libipt_prefix
+@@ -1554,6 +1555,8 @@ Optional Features:
+ --enable-profiling enable profiling of GDB
+ --enable-codesign=CERT sign gdb with 'codesign -s CERT'
+ --disable-rpath do not hardcode runtime library paths
++ --enable-source-highlight
++ enable source-highlight for source listings
+ --enable-libmcheck Try linking with -lmcheck if available
+ --enable-werror treat compile warnings as errors
+ --enable-build-warnings enable build-time compiler warnings if gcc is used
+@@ -11393,13 +11396,30 @@ fi
+
+ SRCHIGH_LIBS=
+ SRCHIGH_CFLAGS=
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for the source-highlight library" >&5
++
++# Check whether --enable-source-highlight was given.
++if test "${enable_source_highlight+set}" = set; then :
++ enableval=$enable_source_highlight; case "${enableval}" in
++ yes) enable_source_highlight=yes ;;
++ no) enable_source_highlight=no ;;
++ *) as_fn_error $? "bad value ${enableval} for source-highlight option" "$LINENO" 5 ;;
++esac
++else
++ enable_source_highlight=auto
++fi
++
++
++if test "${enable_source_highlight}" != "no"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for the source-highlight library" >&5
+ $as_echo_n "checking for the source-highlight library... " >&6; }
+-if test "${pkg_config_prog_path}" = "missing"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no - pkg-config not found" >&5
++ if test "${pkg_config_prog_path}" = "missing"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no - pkg-config not found" >&5
+ $as_echo "no - pkg-config not found" >&6; }
+-else
+- if ${pkg_config_prog_path} --exists source-highlight; then
++ if test "${enable_source_highlight}" = "yes"; then
++ as_fn_error $? "pkg-config was not found in your system" "$LINENO" 5
++ fi
++ else
++ if ${pkg_config_prog_path} --exists source-highlight; then
+ SRCHIGH_CFLAGS=`${pkg_config_prog_path} --cflags source-highlight`
+ SRCHIGH_LIBS=`${pkg_config_prog_path} --libs source-highlight`
+
+@@ -11407,10 +11427,14 @@ $as_echo "#define HAVE_SOURCE_HIGHLIGHT 1" >>confdefs.h
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+- else
++ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
+- fi
++ if test "${enable_source_highlight}" = "yes"; then
++ as_fn_error $? "source-highlight was not found in your system" "$LINENO" 5
++ fi
++ fi
++ fi
+ fi
+
+
+diff --git a/gdb/configure.ac b/gdb/configure.ac
+index 8ddd0fda61..1318c8d008 100644
+--- a/gdb/configure.ac
++++ b/gdb/configure.ac
+@@ -1220,19 +1220,38 @@ AM_CONDITIONAL(HAVE_GUILE, test "${have_libguile}" != no)
+
+ SRCHIGH_LIBS=
+ SRCHIGH_CFLAGS=
+-AC_MSG_CHECKING([for the source-highlight library])
+-if test "${pkg_config_prog_path}" = "missing"; then
+- AC_MSG_RESULT([no - pkg-config not found])
+-else
+- if ${pkg_config_prog_path} --exists source-highlight; then
++
++AC_ARG_ENABLE(source-highlight,
++ AS_HELP_STRING([--enable-source-highlight],
++ [enable source-highlight for source listings]),
++ [case "${enableval}" in
++ yes) enable_source_highlight=yes ;;
++ no) enable_source_highlight=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for source-highlight option) ;;
++esac],
++[enable_source_highlight=auto])
++
++if test "${enable_source_highlight}" != "no"; then
++ AC_MSG_CHECKING([for the source-highlight library])
++ if test "${pkg_config_prog_path}" = "missing"; then
++ AC_MSG_RESULT([no - pkg-config not found])
++ if test "${enable_source_highlight}" = "yes"; then
++ AC_MSG_ERROR([pkg-config was not found in your system])
++ fi
++ else
++ if ${pkg_config_prog_path} --exists source-highlight; then
+ SRCHIGH_CFLAGS=`${pkg_config_prog_path} --cflags source-highlight`
+ SRCHIGH_LIBS=`${pkg_config_prog_path} --libs source-highlight`
+ AC_DEFINE([HAVE_SOURCE_HIGHLIGHT], 1,
+ [Define to 1 if the source-highlight library is available])
+ AC_MSG_RESULT([yes])
+- else
++ else
+ AC_MSG_RESULT([no])
+- fi
++ if test "${enable_source_highlight}" = "yes"; then
++ AC_MSG_ERROR([source-highlight was not found in your system])
++ fi
++ fi
++ fi
+ fi
+ AC_SUBST(SRCHIGH_LIBS)
+ AC_SUBST(SRCHIGH_CFLAGS)
+--
+2.21.0
+