summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-6.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /sys-devel/gcc/gcc-6.4.0-r1.ebuild
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'sys-devel/gcc/gcc-6.4.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-6.4.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-6.4.0-r1.ebuild b/sys-devel/gcc/gcc-6.4.0-r1.ebuild
new file mode 100644
index 000000000000..5fd035bb54ef
--- /dev/null
+++ b/sys-devel/gcc/gcc-6.4.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.2"
+UCLIBC_VER="1.0"
+
+inherit toolchain
+
+# unkeyworded for testing bug #641474
+#KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+}