summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-4.4.7-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /sys-devel/gcc/gcc-4.4.7-r3.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'sys-devel/gcc/gcc-4.4.7-r3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.4.7-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.4.7-r3.ebuild b/sys-devel/gcc/gcc-4.4.7-r3.ebuild
new file mode 100644
index 000000000000..75b290303ee9
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.4.7-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PATCH_VER="2"
+UCLIBC_VER="1.0"
+
+inherit eutils toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+}