summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-13.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 17:57:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 17:57:56 +0000
commit79be8f00e2aa293669b8e22e1ef02d2d5c5f9e25 (patch)
treeee4847d4f20721d819ed71a1e94bb04ff1a8ee4a /sys-devel/gcc/gcc-13.0.9999.ebuild
parent61f62e5edc868fc4ae3b92af397397ee5056578a (diff)
gentoo auto-resync : 16:01:2023 - 17:57:56
Diffstat (limited to 'sys-devel/gcc/gcc-13.0.9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-13.0.9999.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-devel/gcc/gcc-13.0.9999.ebuild b/sys-devel/gcc/gcc-13.0.9999.ebuild
deleted file mode 100644
index 121075573253..000000000000
--- a/sys-devel/gcc/gcc-13.0.9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-TOOLCHAIN_PATCH_DEV="sam"
-PATCH_GCC_VER="13.1.0"
-MUSL_GCC_VER="13.1.0"
-
-if [[ $(ver_cut 3) == 9999 ]] ; then
- MY_PV_2=$(ver_cut 2)
- MY_PV_3=$(($(ver_cut 3) - 9998))
- if [[ ${MY_PV_2} == 0 ]] ; then
- MY_PV_2=0
- MY_PV_3=0
- else
- MY_PV_2=$(($(ver_cut 2) - 1))
- fi
-
- # e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
-fi
-
-inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=master
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-# Technically only if USE=hardened *too* right now, but no point in complicating it further.
-# If GCC is enabling CET by default, we need glibc to be built with support for it.
-# bug #830454
-RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
-DEPEND="${RDEPEND}"
-BDEPEND="${CATEGORY}/binutils[cet(-)?]"
-
-src_prepare() {
- local p upstreamed_patches=(
- # add them here
- )
- for p in "${upstreamed_patches[@]}"; do
- rm -v "${WORKDIR}/patch/${p}" || die
- done
-
- toolchain_src_prepare
-
- eapply_user
-}