summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-11.3.1_p20221209.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
commit2099ff9b640e648be67527e29760263a7c6274e5 (patch)
tree238358af0ba45fd8fcc6cd4679736d6c4f07f851 /sys-devel/gcc/gcc-11.3.1_p20221209.ebuild
parentd198e0ebeee70707545d19ee3beb1de70802cc7c (diff)
gentoo auto-resync : 28:04:2023 - 05:11:40
Diffstat (limited to 'sys-devel/gcc/gcc-11.3.1_p20221209.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.3.1_p20221209.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-devel/gcc/gcc-11.3.1_p20221209.ebuild b/sys-devel/gcc/gcc-11.3.1_p20221209.ebuild
deleted file mode 100644
index 4aaa59aed4eb..000000000000
--- a/sys-devel/gcc/gcc-11.3.1_p20221209.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-TOOLCHAIN_PATCH_SUFFIX="xz"
-TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="3"
-PATCH_GCC_VER="11.4.0"
-MUSL_VER="2"
-MUSL_GCC_VER="11.4.0"
-
-if [[ $(ver_cut 3) == 9999 ]] ; then
- MY_PV_2=$(ver_cut 2)
- if [[ ${MY_PV_2} == 0 ]] ; then
- MY_PV_2=0
- else
- MY_PV_2=$(($(ver_cut 2) - 1))
- fi
-
- # e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
-fi
-
-inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- # Technically only if USE=hardened *too* right now, but no point in complicating it further.
- # If GCC is enabling CET by default, we need glibc to be built with support for it.
- # bug #830454
- RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
- DEPEND="${RDEPEND}"
- BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
-fi
-
-src_prepare() {
- local p upstreamed_patches=(
- # add them here
- )
- for p in "${upstreamed_patches[@]}"; do
- rm -v "${WORKDIR}/patch/${p}" || die
- done
-
- toolchain_src_prepare
-
- eapply_user
-}