summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-11.0.1_pre9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-devel/gcc/gcc-11.0.1_pre9999.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-devel/gcc/gcc-11.0.1_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.0.1_pre9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-11.0.1_pre9999.ebuild b/sys-devel/gcc/gcc-11.0.1_pre9999.ebuild
new file mode 100644
index 000000000000..7734b7517cc4
--- /dev/null
+++ b/sys-devel/gcc/gcc-11.0.1_pre9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_GCC_VER="11.0.0"
+PATCH_VER="6"
+
+inherit toolchain
+
+# Don't keyword live ebuilds
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+EGIT_BRANCH=master
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ has_version '>=sys-libs/glibc-2.32-r1' && rm -v "${WORKDIR}/patch/23_all_disable-riscv32-ABIs.patch"
+ toolchain_src_prepare
+}