summaryrefslogtreecommitdiff
path: root/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
commit65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (patch)
tree8a0a31fde569e875a6a429ce5473050781aa7803 /sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild
parent29d63ef1ebd8704a96d50408d409b9ef0ff3787b (diff)
gentoo auto-resync : 09:06:2023 - 09:47:51
Diffstat (limited to 'sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild')
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild
index c144abe8aca5..c4d1c48409c4 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit toolchain flag-o-matic autotools prefix toolchain-funcs
+inherit flag-o-matic autotools prefix toolchain-funcs
GCC_VERS=${PV/_p*/}
APPLE_VERS="${PV/*_p/}.3"
@@ -42,6 +42,17 @@ S=${WORKDIR}/gcc-${APPLE_VERS}
# TPREFIX is the prefix of the CTARGET installation
export TPREFIX=${TPREFIX:-${EPREFIX}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} = ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
do_bootstrap() {
is_crosscompile && return 1
[[ ${CHOST} != ${CBUILD} ]] && return 1