summaryrefslogtreecommitdiff
path: root/sys-devel/distcc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /sys-devel/distcc/files
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'sys-devel/distcc/files')
-rw-r--r--sys-devel/distcc/files/3.2/conf40
-rw-r--r--sys-devel/distcc/files/3.2/distcc-config180
-rw-r--r--sys-devel/distcc/files/3.2/init31
-rw-r--r--sys-devel/distcc/files/distcc-3.0-fix-fortify.patch11
-rw-r--r--sys-devel/distcc/files/distcc-3.2_rc1-freedesktop.patch79
-rw-r--r--sys-devel/distcc/files/distcc-3.2_rc1-gssapi.patch36
-rw-r--r--sys-devel/distcc/files/distcc-3.2_rc1-python.patch246
-rw-r--r--sys-devel/distcc/files/distccd.service10
8 files changed, 0 insertions, 633 deletions
diff --git a/sys-devel/distcc/files/3.2/conf b/sys-devel/distcc/files/3.2/conf
deleted file mode 100644
index c499271685e9..000000000000
--- a/sys-devel/distcc/files/3.2/conf
+++ /dev/null
@@ -1,40 +0,0 @@
-# /etc/conf.d/distccd: config file for /etc/init.d/distccd
-
-DISTCCD_OPTS=""
-
-# this is the distccd executable
-DISTCCD_EXEC="/usr/bin/distccd"
-
-# this is where distccd will store its pid file
-DISTCCD_PIDFILE="/var/run/distccd/distccd.pid"
-
-# set this option to run distccd with extra parameters
-# Default port is 3632. For most people the default is okay.
-DISTCCD_OPTS="${DISTCCD_OPTS} --port 3632"
-
-# Logging
-# You can change some logging options here:
-# --log-file FILE
-# --log-level LEVEL [critical,error,warning, notice, info, debug]
-#
-# Leaving --log-file blank will log to syslog
-# example: --log-file /dev/null --log-level warning
-# example: --log-level critical
-
-DISTCCD_OPTS="${DISTCCD_OPTS} --log-level critical"
-
-# SECURITY NOTICE:
-# It is HIGHLY recommended that you use the --listen option
-# for increased security. You can specify an IP to permit connections
-# from or a CIDR mask
-# --listen accepts only a single IP
-# --allow is now mandatory as of distcc-2.18.
-# example: --allow 192.168.0.0/24
-# example: --allow 192.168.0.5 --allow 192.168.0.150
-# example: --listen 192.168.0.2
-DISTCCD_OPTS="${DISTCCD_OPTS} --allow 192.168.0.0/24"
-#DISTCCD_OPTS="${DISTCCD_OPTS} --listen 192.168.0.2"
-
-# set this for niceness
-# Default is 15
-DISTCCD_OPTS="${DISTCCD_OPTS} -N 15"
diff --git a/sys-devel/distcc/files/3.2/distcc-config b/sys-devel/distcc/files/3.2/distcc-config
deleted file mode 100644
index 4902a9a42c5a..000000000000
--- a/sys-devel/distcc/files/3.2/distcc-config
+++ /dev/null
@@ -1,180 +0,0 @@
-#!/usr/bin/env python
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-import os, re, signal, subprocess, sys
-
-options=[
- '--get-hosts',
- '--set-hosts',
- '--get-verbose',
- '--set-verbose',
- '--get-log',
- '--set-log',
- '--update-masquerade',
- '--update-masquerade-with-crossdev',
- '--help',
- '--get-env',
- '--set-env'
-]
-
-tmpcmdline=sys.argv[1:]
-cmdline=[]
-
-eprefix = '@EPREFIX@'
-bindir = os.path.join(eprefix, 'usr', 'bin')
-sbindir = os.path.join(eprefix, 'usr', 'sbin')
-libdir = os.path.join(eprefix, '@libdir@')
-sysconfdir = os.path.join(eprefix, 'etc')
-
-gcc_config = os.path.join(bindir, 'gcc-config')
-env_update = os.path.join(sbindir, 'env-update')
-envfile = os.path.join(sysconfdir, 'env.d', '02distcc')
-default_distcc_dir = os.path.join(sysconfdir, 'distcc')
-hostfile = os.path.join(default_distcc_dir, 'hosts')
-distcc_path = os.path.join(bindir, 'distcc')
-dccc_dir = os.path.join(libdir, 'distcc', 'bin')
-
-def exithandler(foo,bar):
- os.kill(0,signal.SIGKILL)
- sys.exit(1)
-
-signal.signal(signal.SIGINT,exithandler)
-
-def isroot(ret=0):
- if os.getuid() != 0:
- if ret == 0:
- print('!!! %s %s must be run as root' % (sys.argv[:1][0],tmpcmdline[0]))
- sys.exit(1)
- else:
- retval = 0
- else:
- retval = 1
- return retval
-
-def writeenv(var,value):
- isroot()
- distcc_env = []
- distcc_env = open(envfile, 'r').readlines()
- distcc_env_new = open(envfile, 'w')
- for i in range(len(distcc_env)):
- if re.compile(var+'="(.*)"').match(distcc_env[i]):
- distcc_env[i] = var+'="'+value+'"\n'
- distcc_env_new.write(distcc_env[i])
- #print('Set %s to: %s ' % (var,value))
- subprocess.Popen(env_update, shell=True)
- print('If you want to use these new settings in an existing shell,')
- print('you need to "source /etc/profile" to get the changes.')
-
-def readenv(var):
- distcc_env = open(envfile, 'r').read()
- match = re.compile(var+'="(.*)"').search(distcc_env)
- if match:
- print(var+'='+match.group(1))
- else:
- print(var,'not set.')
-
-def installlink(chost='', version=''):
- for file in ['gcc', 'cc', 'c++', 'g++']:
- if not chost == '':
- file = '%s-%s' % (chost,file)
- if not version == '':
- file = '%s-%s' % (file,version)
- path = os.path.join(dccc_dir,file)
- if os.path.exists(os.path.join(bindir,file)):
- if not os.path.exists(path):
- print('Creating %s symlink...' % (path))
- os.symlink(distcc_path,path)
- #else:
- # print('Already exists. Skipping...')
-
-def installlinks():
- p = subprocess.Popen([gcc_config+" -C -l"], shell=True, stdout=subprocess.PIPE)
- lines = p.stdout.read().rstrip().split('\n')
- for line in lines:
- columns = line.split()
- if len(columns) >= 2:
- matches = re.match("(.*)-(.*)", columns[1])
- chost = matches.group(1)
- version = matches.group(2)
- installlink(chost)
- installlink(chost, version)
-
-def uninstalllinks():
- for root, dirs, files in os.walk(dccc_dir):
- for file in files:
- os.remove(os.path.join(root, file))
-
-def createdistccdir(dir):
- if not os.path.exists(dir):
- os.mkdir(dir)
- os.chmod(dir, 0o755)
-
-for x in tmpcmdline:
- if not x:
- continue
- if x[0:2]=="--":
- if not x in options:
- print("!!! Error: %s is an invalid option." % (x))
- sys.exit(1)
- else:
- cmdline = x
-
-if '--get-hosts' in tmpcmdline:
- HOSTS_ENV = os.environ.get('DISTCC_HOSTS')
- HOSTS_HOME = os.path.join(os.environ.get('HOME'), '.distcc', 'hosts')
- if HOSTS_ENV:
- print(HOSTS_ENV)
- elif os.path.isfile(HOSTS_HOME) and os.path.getsize(HOSTS_HOME) != 0:
- print(HOSTS_HOME)
- elif os.path.exists(hostfile):
- print(open(hostfile, 'r').read().rstrip())
- else:
- print('No configuration file found. Setup your hosts with --set-hosts.')
-elif '--set-hosts' in tmpcmdline:
- if isroot(1):
- PATH = default_distcc_dir
- else:
- PATH = os.path.join(os.environ.get('HOME'), '.distcc')
- createdistccdir(PATH)
- open(os.path.join(PATH, 'hosts'), 'w').write(cmdline + '\n')
-elif '--get-verbose' in tmpcmdline:
- readenv('DISTCC_VERBOSE')
-elif '--set-verbose' in tmpcmdline:
- writeenv('DISTCC_VERBOSE',tmpcmdline[1])
-elif '--get-log' in tmpcmdline:
- readenv('DISTCC_LOG')
-elif '--set-log' in tmpcmdline:
- writeenv('DISTCC_LOG',tmpcmdline[1])
-elif '--update-masquerade' in tmpcmdline:
- isroot()
- uninstalllinks()
- print('Creating symlinks...')
- installlink()
- installlinks()
-elif '--update-masquerade-with-crossdev' in tmpcmdline:
- isroot()
- uninstalllinks()
- print('Creating symlinks...')
- installlinks()
-elif '--get-env' in tmpcmdline:
- if len(tmpcmdline) == 1:
- print(open(envfile, 'r').read().rstrip())
- elif len(tmpcmdline) == 2:
- readenv(tmpcmdline[1])
- else:
- print('!!! Error: Specify only one variable.')
-elif '--set-env' in tmpcmdline:
- if len(tmpcmdline) > 2 and len(tmpcmdline) <= 3:
- isroot()
- writeenv(tmpcmdline[1],tmpcmdline[2])
- else:
- print('!!! Error: Awaiting two parameters.')
-else:
- cmd = sys.argv[:1][0]
- print('Usage: %s --set-hosts DISTCC_HOSTS | --get-hosts' % (cmd))
- print(' %s --set-verbose { 0 | 1 } | --get-verbose' % (cmd))
- print(' %s --set-log FILE | --get-log' % (cmd))
- print(' %s --set-env VARIABLE VALUE | --get-env [VARIABLE]' % (cmd))
- print(' %s --update-masquerade' % (cmd))
- print(' %s --update-masquerade-with-crossdev' % (cmd))
diff --git a/sys-devel/distcc/files/3.2/init b/sys-devel/distcc/files/3.2/init
deleted file mode 100644
index e89dcb3702b7..000000000000
--- a/sys-devel/distcc/files/3.2/init
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
- use avahi-daemon ypbind
-}
-
-start() {
- ebegin "Starting distccd"
-
- if [ ! -e /var/run/distccd ] ; then
- mkdir -p /var/run/distccd
- chown distcc:daemon /var/run/distccd
- fi
-
- # Load PATH and GCC_SPECS from gcc-config, bug #262773
- eval "$(gcc-config -E)"
-
- start-stop-daemon --start --quiet --exec "${DISTCCD_EXEC}" --user distcc -- \
- --daemon --pid-file "${DISTCCD_PIDFILE}" \
- ${DISTCCD_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping distccd"
- start-stop-daemon --stop --quiet --pidfile "${DISTCCD_PIDFILE}"
- eend $?
-}
diff --git a/sys-devel/distcc/files/distcc-3.0-fix-fortify.patch b/sys-devel/distcc/files/distcc-3.0-fix-fortify.patch
deleted file mode 100644
index 8edc330e324b..000000000000
--- a/sys-devel/distcc/files/distcc-3.0-fix-fortify.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru a/src/snprintf.h b/src/snprintf.h
---- a/src/snprintf.h 2008-08-06 15:52:06.000000000 -0500
-+++ b/src/snprintf.h 2009-01-04 15:19:22.000000000 -0600
-@@ -7,6 +7,7 @@
- */
-
- #include <stdarg.h>
-+#include "config.h"
-
- #ifdef __GNUC__
- /** Use gcc attribute to check printf fns. a1 is the 1-based index of
diff --git a/sys-devel/distcc/files/distcc-3.2_rc1-freedesktop.patch b/sys-devel/distcc/files/distcc-3.2_rc1-freedesktop.patch
deleted file mode 100644
index 8f0d8d77a12b..000000000000
--- a/sys-devel/distcc/files/distcc-3.2_rc1-freedesktop.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff -Naur distcc-3.2rc1.orig/Makefile.in distcc-3.2rc1/Makefile.in
---- distcc-3.2rc1.orig/Makefile.in 2011-10-26 11:07:15.000000000 +0900
-+++ distcc-3.2rc1/Makefile.in 2011-10-27 16:57:46.815272689 +0900
-@@ -50,13 +50,14 @@
- includedir = @includedir@
- oldincludedir = /usr/include
- docdir = @docdir@
--pkgdatadir = $(datadir)/@PACKAGE_NAME@
-+icondir = $(datadir)/pixmaps
-+desktopdir = $(datadir)/applications
-
- include_server_builddir = $(builddir)/_include_server
-
- # These must be done from here, not from autoconf, because they can
- # contain variable expansions written in Make syntax. Ew.
--DIR_DEFS = -DSYSCONFDIR="\"${sysconfdir}\"" -DPKGDATADIR="\"${pkgdatadir}\""
-+DIR_DEFS = -DSYSCONFDIR="\"${sysconfdir}\"" -DICONDIR="\"${icondir}\""
-
- # arguments to pkgconfig
- GNOME_PACKAGES = @GNOME_PACKAGES@
-@@ -1016,7 +1017,8 @@
- @echo " documents $(DESTDIR)$(docdir)"
- @echo " programs $(DESTDIR)$(bindir)"
- @echo " system configuration $(DESTDIR)$(sysconfdir)"
-- @echo " shared data files $(DESTDIR)$(pkgdatadir)"
-+ @echo " icons $(DESTDIR)$(icondir)"
-+ @echo " .desktop file $(DESTDIR)$(desktopdir)"
-
-
- # install-sh can't handle multiple arguments, but we don't need any
-@@ -1108,10 +1110,10 @@
- done
-
- install-gnome-data: $(gnome_data)
-- $(mkinstalldirs) "$(DESTDIR)$(pkgdatadir)"
-- for p in $(gnome_data); do \
-- $(INSTALL_DATA) "$$p" "$(DESTDIR)$(pkgdatadir)" || exit 1; \
-- done
-+ $(mkinstalldirs) "$(DESTDIR)$(icondir)"
-+ $(mkinstalldirs) "$(DESTDIR)$(desktopdir)"
-+ $(INSTALL_DATA) gnome/distccmon-gnome-icon.png "$(DESTDIR)$(icondir)" || exit 1
-+ $(INSTALL_DATA) gnome/distccmon-gnome.desktop "$(DESTDIR)$(desktopdir)" || exit 1
-
- install-conf: $(conf_files) $(default_files)
- $(mkinstalldirs) "$(DESTDIR)$(sysconfdir)/distcc"
-diff -Naur distcc-3.2rc1.orig/gnome/distccmon-gnome.desktop distcc-3.2rc1/gnome/distccmon-gnome.desktop
---- distcc-3.2rc1.orig/gnome/distccmon-gnome.desktop 2011-04-06 03:58:58.000000000 +0900
-+++ distcc-3.2rc1/gnome/distccmon-gnome.desktop 2011-10-27 17:01:50.792242592 +0900
-@@ -1,6 +1,4 @@
- [Desktop Entry]
--Version=0.9.4
--Encoding=UTF-8
- Exec=distccmon-gnome
- Name=distcc monitor
- Name[sv]=distcc övervakare
-@@ -8,9 +6,9 @@
- GenericName[sv]=Distribuerad kompilerings-övervakare
- Comment=Graphical view of distributed compile tasks
- Comment[sv]=Grafisk vy av distribuerade kompileringsuppgifter
--Icon=distccmon-gnome-icon.png
-+Icon=distccmon-gnome-icon
- TryExec=distccmon-gnome
- Terminal=false
- Type=Application
--Categories=GNOME;Application;Development;
-+Categories=GNOME;Development;
- StartupNotify=true
-diff -Naur distcc-3.2rc1.orig/src/mon-gnome.c distcc-3.2rc1/src/mon-gnome.c
---- distcc-3.2rc1.orig/src/mon-gnome.c 2008-12-03 06:50:25.000000000 +0900
-+++ distcc-3.2rc1/src/mon-gnome.c 2011-10-27 16:54:50.220566026 +0900
-@@ -599,7 +599,7 @@
-
- #if GTK_CHECK_VERSION(2,2,0)
- gtk_window_set_icon_from_file (GTK_WINDOW (mainwin),
-- PKGDATADIR "/distccmon-gnome-icon.png",
-+ ICONDIR "/distccmon-gnome-icon.png",
- NULL);
- #endif
-
diff --git a/sys-devel/distcc/files/distcc-3.2_rc1-gssapi.patch b/sys-devel/distcc/files/distcc-3.2_rc1-gssapi.patch
deleted file mode 100644
index 73551f8a7b80..000000000000
--- a/sys-devel/distcc/files/distcc-3.2_rc1-gssapi.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur distcc-3.2rc1.orig/configure.ac distcc-3.2rc1/configure.ac
---- distcc-3.2rc1.orig/configure.ac 2011-10-21 13:40:55.000000000 +0900
-+++ distcc-3.2rc1/configure.ac 2011-10-27 18:06:58.938922585 +0900
-@@ -15,6 +15,8 @@
- AC_CONFIG_HEADERS(src/config.h)
- AC_CANONICAL_HOST
-
-+PKG_PROG_PKG_CONFIG
-+
- # FreeBSD installs its version of libpopt into /usr/local/, but does
- # not put that on the default library and header path.
- # Solaris doesn't even ship libpopt. We used to add that path if
-@@ -502,16 +504,17 @@
- [provide mutual authentication services via the GSS-API])])
-
- if test x"$with_auth" = xyes; then
-- AC_SEARCH_LIBS([gss_init_sec_context],
-- [gssapi gssapi_krb5],
-- AC_DEFINE(HAVE_GSSAPI, 1, [Define if the GSS_API is available])
-+ PKG_CHECK_MODULES(GSSAPI, libgssglue,
-+ [AC_DEFINE(HAVE_GSSAPI, 1, [Define if the GSS_API is available])
-+ CFLAGS="$CFLAGS $GSSAPI_CFLAGS"
-+ LIBS="$LIBS $GSSAPI_LIBS"
- AUTH_COMMON_OBJS="src/auth_common.o"
- AUTH_DISTCC_OBJS="src/auth_distcc.o"
-- AUTH_DISTCCD_OBJS="src/auth_distccd.o",
-- AC_MSG_FAILURE([--with-auth was given but no GSS-API library found])
-+ AUTH_DISTCCD_OBJS="src/auth_distccd.o"],
-+ [AC_MSG_FAILURE([--with-auth was given but no GSS-API library found])
- AUTH_COMMON_OBJS=""
- AUTH_DISTCC_OBJS=""
-- AUTH_DISTCCD_OBJS="")
-+ AUTH_DISTCCD_OBJS=""])
- fi
-
- AC_SUBST(AUTH_COMMON_OBJS)
diff --git a/sys-devel/distcc/files/distcc-3.2_rc1-python.patch b/sys-devel/distcc/files/distcc-3.2_rc1-python.patch
deleted file mode 100644
index 409b5a19d321..000000000000
--- a/sys-devel/distcc/files/distcc-3.2_rc1-python.patch
+++ /dev/null
@@ -1,246 +0,0 @@
-diff -Naur distcc-3.2rc1.orig/bench/statistics.py distcc-3.2rc1/bench/statistics.py
---- distcc-3.2rc1.orig/bench/statistics.py 2008-12-03 06:50:21.000000000 +0900
-+++ distcc-3.2rc1/bench/statistics.py 2011-10-27 17:05:08.418023081 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python2.2
-+#! /usr/bin/env python
-
- # benchmark -- automated system for testing distcc correctness
- # and performance on various source trees.
-diff -Naur distcc-3.2rc1.orig/configure.ac distcc-3.2rc1/configure.ac
---- distcc-3.2rc1.orig/configure.ac 2011-10-21 13:40:55.000000000 +0900
-+++ distcc-3.2rc1/configure.ac 2011-10-27 17:05:31.179112690 +0900
-@@ -243,7 +243,7 @@
- #
- # NB: Cannot use AC_CONFIG_LIBOBJ_DIR here, because it's not present
- # in autoconf 2.53.
--AC_PATH_PROGS(PYTHON, [python2.6 python-2.6 python2.5 python-2.5 python2.4 python-2.4 python])
-+AC_PATH_PROGS(PYTHON, [python])
- AC_ARG_VAR(PYTHON, [Python interpreter])
- # Python 1 doesn't even support -V
- if ! "$PYTHON" -V 2>&1 | grep "^Python" >/dev/null; then
-diff -Naur distcc-3.2rc1.orig/include_server/basics.py distcc-3.2rc1/include_server/basics.py
---- distcc-3.2rc1.orig/include_server/basics.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/basics.py 2011-10-27 17:05:08.421023097 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
- #
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/basics_test.py distcc-3.2rc1/include_server/basics_test.py
---- distcc-3.2rc1.orig/include_server/basics_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/basics_test.py 2011-10-27 17:05:08.421023097 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/c_extensions_test.py distcc-3.2rc1/include_server/c_extensions_test.py
---- distcc-3.2rc1.orig/include_server/c_extensions_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/c_extensions_test.py 2011-10-27 17:05:08.421023097 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/cache_basics.py distcc-3.2rc1/include_server/cache_basics.py
---- distcc-3.2rc1.orig/include_server/cache_basics.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/cache_basics.py 2011-10-27 17:05:08.422023101 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/compiler_defaults.py distcc-3.2rc1/include_server/compiler_defaults.py
---- distcc-3.2rc1.orig/include_server/compiler_defaults.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/compiler_defaults.py 2011-10-27 17:05:08.422023101 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/compress_files.py distcc-3.2rc1/include_server/compress_files.py
---- distcc-3.2rc1.orig/include_server/compress_files.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/compress_files.py 2011-10-27 17:05:08.422023101 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_analyzer.py distcc-3.2rc1/include_server/include_analyzer.py
---- distcc-3.2rc1.orig/include_server/include_analyzer.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_analyzer.py 2011-10-27 17:05:08.422023101 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_analyzer_memoizing_node.py distcc-3.2rc1/include_server/include_analyzer_memoizing_node.py
---- distcc-3.2rc1.orig/include_server/include_analyzer_memoizing_node.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_analyzer_memoizing_node.py 2011-10-27 17:05:08.422023101 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_analyzer_memoizing_node_test.py distcc-3.2rc1/include_server/include_analyzer_memoizing_node_test.py
---- distcc-3.2rc1.orig/include_server/include_analyzer_memoizing_node_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_analyzer_memoizing_node_test.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_analyzer_test.py distcc-3.2rc1/include_server/include_analyzer_test.py
---- distcc-3.2rc1.orig/include_server/include_analyzer_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_analyzer_test.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_server.py distcc-3.2rc1/include_server/include_server.py
---- distcc-3.2rc1.orig/include_server/include_server.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_server.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/include_server_test.py distcc-3.2rc1/include_server/include_server_test.py
---- distcc-3.2rc1.orig/include_server/include_server_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/include_server_test.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/macro_eval.py distcc-3.2rc1/include_server/macro_eval.py
---- distcc-3.2rc1.orig/include_server/macro_eval.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/macro_eval.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/macro_eval_test.py distcc-3.2rc1/include_server/macro_eval_test.py
---- distcc-3.2rc1.orig/include_server/macro_eval_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/macro_eval_test.py 2011-10-27 17:05:08.423023105 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/mirror_path.py distcc-3.2rc1/include_server/mirror_path.py
---- distcc-3.2rc1.orig/include_server/mirror_path.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/mirror_path.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/mirror_path_test.py distcc-3.2rc1/include_server/mirror_path_test.py
---- distcc-3.2rc1.orig/include_server/mirror_path_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/mirror_path_test.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/parse_command.py distcc-3.2rc1/include_server/parse_command.py
---- distcc-3.2rc1.orig/include_server/parse_command.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/parse_command.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/parse_command_test.py distcc-3.2rc1/include_server/parse_command_test.py
---- distcc-3.2rc1.orig/include_server/parse_command_test.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/parse_command_test.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/parse_file.py distcc-3.2rc1/include_server/parse_file.py
---- distcc-3.2rc1.orig/include_server/parse_file.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/parse_file.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/parse_file_test.py distcc-3.2rc1/include_server/parse_file_test.py
---- distcc-3.2rc1.orig/include_server/parse_file_test.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/parse_file_test.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/run.py distcc-3.2rc1/include_server/run.py
---- distcc-3.2rc1.orig/include_server/run.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/run.py 2011-10-27 17:05:08.424023109 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/setup.py distcc-3.2rc1/include_server/setup.py
---- distcc-3.2rc1.orig/include_server/setup.py 2011-04-06 03:58:59.000000000 +0900
-+++ distcc-3.2rc1/include_server/setup.py 2011-10-27 17:05:08.425023113 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
-
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/include_server/statistics.py distcc-3.2rc1/include_server/statistics.py
---- distcc-3.2rc1.orig/include_server/statistics.py 2008-12-03 06:50:31.000000000 +0900
-+++ distcc-3.2rc1/include_server/statistics.py 2011-10-27 17:05:08.425023113 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/python2.4
-+#! /usr/bin/python
- #
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/test/onetest.py distcc-3.2rc1/test/onetest.py
---- distcc-3.2rc1.orig/test/onetest.py 2008-12-03 06:50:22.000000000 +0900
-+++ distcc-3.2rc1/test/onetest.py 2011-10-27 17:05:08.432023140 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2.4
-+#!/usr/bin/python
- #
- # Copyright 2007 Google Inc.
- #
-diff -Naur distcc-3.2rc1.orig/test/testdistcc.py distcc-3.2rc1/test/testdistcc.py
---- distcc-3.2rc1.orig/test/testdistcc.py 2011-10-21 11:40:49.000000000 +0900
-+++ distcc-3.2rc1/test/testdistcc.py 2011-10-27 17:05:08.432023140 +0900
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python2.2
-+#! /usr/bin/env python
-
- # Copyright (C) 2002, 2003, 2004 by Martin Pool <mbp@samba.org>
- # Copyright 2007 Google Inc.
diff --git a/sys-devel/distcc/files/distccd.service b/sys-devel/distcc/files/distccd.service
deleted file mode 100644
index 3eb61396b84c..000000000000
--- a/sys-devel/distcc/files/distccd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Distccd: A Distributed Compilation Server
-After=network.target
-
-[Service]
-User=distcc
-ExecStart=/usr/bin/distccd --verbose --no-detach --daemon --port 3632 -N 15 --allow $ALLOWED_SERVERS
-
-[Install]
-WantedBy=multi-user.target